如何让低版本IE浏览器支持HTML5和CSS3

简介:
在默认状态下,低版本的IE浏览器是不支持HTML5和CSS3的,很多良好的效果都不能够使用,这不能不说是一种遗憾,为了弥补此种遗憾,因此产生了很多优秀的插件,下面就介绍比较常用的几种。

一.html5shiv.js插件:

Remy开发的html5shiv.js能够在低版本的IE浏览器中创建main,header,footer等HTML5元素。也就是说使用javascript能创建这些本来不存在的HTML5新元素,引用方式如下:

 
1
2
3
<!--[if lt IE 9]>
<script src="html5shiv.js"></script>
<![endif]-->

二.selectivizr.js插件:

此插件提供了大量的低版本IE浏览器不支持的选择器和属性,引用方式如下:

 
1
<!--[if lte IE 8]><script src="selectivizr.js"></script><![endif]-->

上面两个插件的用法这里就不多介绍了,只是告诉大家是有一些方法可以弥补一下低版本的IE浏览器的不足之处。



原文发布时间为:2017-2-10

本文作者:admin

本文来自云栖社区合作伙伴“蚂蚁部落”,了解相关信息可以关注蚂蚁部落

原文链接:如何让低版本IE浏览器支持HTML5和CSS3

相关文章
|
1月前
|
前端开发 Ruby
编程笔记 html5&css&js 054 CSS默认值
编程笔记 html5&css&js 054 CSS默认值
24 4
|
1月前
|
Web App开发 前端开发 JavaScript
CSS容器查询获得主流浏览器支持,是什么?怎么用?
CSS容器查询获得主流浏览器支持,是什么?怎么用?
|
2月前
|
前端开发
(最简单)使用 reset-css 初始化浏览器css样式
(最简单)使用 reset-css 初始化浏览器css样式
29 1
|
2月前
|
Web App开发 JavaScript 前端开发
JavaScript在IE和标准浏览器下的兼容性处理
JavaScript在IE和标准浏览器下的兼容性处理
17 0
|
3月前
|
前端开发
border-radius 兼容 IE8浏览器
border-radius 兼容 IE8浏览器
30 1
|
3月前
|
Web App开发 移动开发 安全
IE浏览器,和Edge浏览器
IE浏览器,和Edge浏览器
|
3月前
|
JavaScript
兼容IE浏览器
兼容IE浏览器
24 0
|
4月前
|
移动开发 前端开发 搜索推荐
(前端开发入门必看)一口气读完HTML5与CSS3基础教程,快速建造前端思维(更新中)
(前端开发入门必看)一口气读完HTML5与CSS3基础教程,快速建造前端思维(更新中)
82 0
|
4月前
|
Web App开发 移动开发 JavaScript
【前端用法】HTML5 Video标签如何屏蔽右键视频另存为的js代码以及如何禁用浏览器控件,Video 禁止鼠标右键下载
【前端用法】HTML5 Video标签如何屏蔽右键视频另存为的js代码以及如何禁用浏览器控件,Video 禁止鼠标右键下载
99 0
|
4月前
|
移动开发 前端开发 JavaScript
HTML5+CSS3+移动web 前端开发入门笔记(二)HTML标签详解(下)
HTML5+CSS3+移动web 前端开发入门笔记(二)HTML标签详解(下)
48 1

相关产品

  • 云迁移中心