zoj 2417 Lowest Bit(简单的模拟)

简介:
Lowest Bit

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input

 

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output

For each A in the input, output a line containing only its lowest bit.


Sample Input

26
88
0


Sample Output

2
8

分析:

(1)因为是100以内的数字所以只要找出能够组成100以内的所有二进制的数字然后一次减直到减后为0时就说明此时减掉的是最小有效位的那个数字。

复制代码
#include <stdio.h>

int main()
{
    int n,bit_num[7],i;
    //得到可以组成100以内的二进制数的组合
    bit_num[0] = 1;
    for(i = 1;i<7;i++)
    bit_num[i] = bit_num[i-1]*2;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=6;i>=0;i--)
        {
            if(n>=bit_num[i])
            n -= bit_num[i];
            if(n==0)break;
        }
        printf("%d\n",bit_num[i]);
    }
    return 0;
}
复制代码
本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/10/05/2712264.html  ,如需转载请自行联系原作者
相关文章
hdu 1196 Lowest Bit(水题)
hdu 1196 Lowest Bit(水题)
41 0
codeforces 339 D.Xenia and Bit Operations(线段树)
输入n,m表示有2^n个数和m个更新,每次更新只把p位置的值改成b,然后输出整个序列运算后的值,而这个运算就比较复杂了, 最下面一层两个数字之间或运算得到原来数目一半的数字,然后两个之间异或运算,得到一半,再或再异或………………,一直到得到一个数字,这个数字就是要求的结果。
53 0
|
人工智能 BI
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
82 0
HDOJ 1196 Lowest Bit(二进制相关的简单题)
HDOJ 1196 Lowest Bit(二进制相关的简单题)
98 0
POJ 2840 Big Clock
POJ 2840 Big Clock
111 0
|
机器学习/深度学习
POJ 1423 Big Number
POJ 1423 Big Number
99 0
ZOJ Problem Set - 3758 素数
ZOJ Problem Set - 3758 素数
100 0