Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
解题思路
使用公式,避免值的范围溢出
实现代码
#include <iostream>
using namespace std;
int main()
{
int n, sum;
while (cin>>n)
{
sum = (n+1)/2.0*n;
cout<<sum<<endl<<endl;
}
return 0;
}
对于这道水题,也真是醉了,如下代码竟然WA:
#include <iostream>
using namespace std;
int main()
{
int n;
while (cin>>n)
cout<<(n+1)/2.0*n<<endl<<endl;
return 0;
}