BGP Next-hop-self 之 -- IGP redistribution

本文涉及的产品
Redis 开源版,标准版 2GB
推荐场景:
搭建游戏排行榜
云数据库 Tair(兼容Redis),内存型 2GB
简介:

【实验目的】

在R1与R4上配置重定向,确保R3与R5之间的网络互相能够访问,(非next-hop-self方式)

 
【实验拓扑】

 

 

【实验基本配置】
R1:
interface FastEthernet0/0
ip address 155.1.146.1 255.255.255.0
!
interface Serial0/0
ip address 155.1.13.1 255.255.255.0
clock rate 2000000
!
router eigrp 2
network 155.1.13.1 0.0.0.0
no auto-summary
!
router bgp 2
neighbor 155.1.13.3 remote-as 2
neighbor 155.1.146.4 remote-as 1
no auto-summary

R3:

interface Loopback0
ip address 155.1.37.3 255.255.255.0
!
interface Serial0/1
ip address 155.1.13.3 255.255.255.0
clock rate 64000
!
router eigrp 2
network 155.1.13.3 0.0.0.0
no auto-summary
!
router bgp 2
network 155.1.37.0 mask 255.255.255.0
neighbor 155.1.13.1 remote-as 2

 
R4:
interface FastEthernet0/0
ip address 155.1.146.4 255.255.255.0
interface Serial0/0
ip address 155.1.45.4 255.255.255.0
clock rate 2000000
router eigrp 1
network 155.1.45.4 0.0.0.0
no auto-summary
router bgp 1
neighbor 155.1.45.5 remote-as 1
neighbor 155.1.146.1 remote-as 2
R5:
interface Loopback0
ip address 155.1.5.5 255.255.255.0
!
interface Serial0/1
ip address 155.1.45.5 255.255.255.0
clock rate 64000
!
router eigrp 1
network 155.1.45.5 0.0.0.0
no auto-summary
!
router bgp 1
network 155.1.5.0 mask 255.255.255.0
neighbor 155.1.45.4 remote-as 1

 
【实验前验证】
R3#show ip bgp
Network Next Hop Metric LocPrf Weight Path
* i155.1.5.0/24 155.1.146.4 0 100 0 1 i
*> 155.1.37.0/24 0.0.0.0 0 32768 i

 
R3#show ip bgp 155.1.5.0
BGP routing table entry for 155.1.5.0/24, version 0
Paths: (1 available, no best path)
Not advertised to any peer
1
155.1.146.4 ( inaccessible) from 155.1.13.1 (155.1.146.1)
Origin IGP, metric 0, localpref 100, valid, internal
在没有配置next-hop-self之前,我们看到结果不可达,原因是,在R3上收到去往155.1.5.0 的下一跳应该是R1的地址(155.1.13.1);由于IGP之间传输BGP路由时不改变下一跳,这就造成了不可达。

 
R3#show ip route 路由表中冶没有任何去放155.1.146 网络的路由
155.1.0.0/24 is subnetted, 2 subnets
C 155.1.13.0 is directly connected, Serial0/1
C 155.1.37.0 is directly connected, Loopback0

 

 

 
【实验配置】
接下来,我们不用next-hop-self,而采用重定向EGP到IGP中,我们在R1与R4上分别将直连网络重定向到IGP来解决不可达的问题。
R1
router eigrp 2
redistribution connected metric 1 1 1 1 1
R4
router eigrp 1
redistribution connected metric 1 1 1 1 1

 

 
【实验验证】
R3#show ip bgp
Network Next Hop Metric LocPrf Weight Path
*>i155.1.5.0/24 155.1.146.4 0 100 0 1 i
*> 155.1.37.0/24 0.0.0.0 0 32768 i

 
注意这里,虽然下一跳没有改变,但路由表中多了一条去往155.1.146.0 的路由,因此路由器知道怎么走。
R3#show ip route
155.1.0.0/24 is subnetted, 4 subnets
D EX 155.1.146.0 [170/2560512256] via 155.1.13.1, 00:01:21, Serial0/1
C 155.1.13.0 is directly connected, Serial0/1
B 155.1.5.0 [200/0] via 155.1.146.4, 00:00:42
C 155.1.37.0 is directly connected, Loopback0

R3#ping 155.1.5.5 source 155.1.37.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.5.5, timeout is 2 seconds:
Packet sent with a source address of 155.1.37.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/48/80 ms


本文转自zcm8483 51CTO博客,原文链接:http://blog.51cto.com/haolun/992836
相关实践学习
基于Redis实现在线游戏积分排行榜
本场景将介绍如何基于Redis数据库实现在线游戏中的游戏玩家积分排行榜功能。
云数据库 Redis 版使用教程
云数据库Redis版是兼容Redis协议标准的、提供持久化的内存数据库服务,基于高可靠双机热备架构及可无缝扩展的集群架构,满足高读写性能场景及容量需弹性变配的业务需求。 产品详情:https://www.aliyun.com/product/kvstore     ------------------------------------------------------------------------- 阿里云数据库体验:数据库上云实战 开发者云会免费提供一台带自建MySQL的源数据库 ECS 实例和一台目标数据库 RDS实例。跟着指引,您可以一步步实现将ECS自建数据库迁移到目标数据库RDS。 点击下方链接,领取免费ECS&RDS资源,30分钟完成数据库上云实战!https://developer.aliyun.com/adc/scenario/51eefbd1894e42f6bb9acacadd3f9121?spm=a2c6h.13788135.J_3257954370.9.4ba85f24utseFl
相关文章
|
6月前
|
网络协议
OSPF,RIP和BGP的路由汇总
OSPF,RIP和BGP的路由汇总
80 0
|
6月前
|
负载均衡 网络协议 算法
IP路由协议(RIP、IGRP、OSPF、IS-IS、BGP)
1、路由分类 路由产生方式: 直接路由:路由器会自动生成本路由器激活端口所在网段的路由条目 静态路由:网络管理员手工配置,静态路由信息在缺省的情况下私有的,不会传递给其他的路由器
|
网络协议 数据库 网络架构
ISIS路由协议(二)
ISIS路由协议
119 0
|
网络协议 网络架构 iOS开发
概述、 BGP AS 、BGP 邻居、 BGP 更新源 、BGP TTL 、BGP路由表、 BGP 同步(下)
文章目录 系列文件 概述 BGP AS BGP 邻居 BGP 更新源 BGP TTL BGP路由表 BGP 同步
466 0
概述、 BGP AS 、BGP 邻居、 BGP 更新源 、BGP TTL 、BGP路由表、 BGP 同步(下)
|
网络协议 算法 数据库
概述、 BGP AS 、BGP 邻居、 BGP 更新源 、BGP TTL 、BGP路由表、 BGP 同步(上)
文章目录 系列文件 概述 BGP AS BGP 邻居 BGP 更新源 BGP TTL BGP路由表 BGP 同步
389 0
概述、 BGP AS 、BGP 邻居、 BGP 更新源 、BGP TTL 、BGP路由表、 BGP 同步(上)
|
网络协议 数据库 网络架构