BGP Route Reflectors and Route Filters

简介:

wKiom1NY0dziObv6AAED5w-2As0967.jpg


sanjose1#show run 
Building configuration... 

Current configuration : 1338 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname sanjose1 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 
!          
interface Serial1/0 
ip address 192.168.1.5 255.255.255.252 
serial restart-delay 0 
clock rate 128000 


router rip 
version 2 
network 192.168.1.0 
no auto-summary 

router bgp 100 
no synchronization 
bgp log-neighbor-changes 
neighbor 192.168.1.6 remote-as 100 
no auto-summary 


no ip http server 
no ip http secure-server 
!control-plane 

gatekeeper 
shutdown  


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 

sanjose2#show run 
Building configuration... 

*Apr 14 13:23:12.559: %SYS-5-CONFIG_I: Configured from console by console 
Current configuration : 1664 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname sanjose2 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 

interface Loopback0 
ip address 10.2.2.1 255.255.255.0 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
ip address 192.168.1.6 255.255.255.252 
serial restart-delay 0 

interface Serial1/1 
ip address 172.24.1.17 255.255.255.0 
serial restart-delay 0 
clock rate 128000 


router rip 
version 2 
network 10.0.0.0 
network 172.24.0.0 
network 192.168.1.0 
no auto-summary 

router bgp 100 
no synchronization 
bgp log-neighbor-changes 
neighbor 172.24.1.18 remote-as 100 
neighbor 172.24.1.18 route-reflector-client    配置路由反射 
neighbor 192.168.1.5 remote-as 100 
neighbor 192.168.1.5 route-reflector-client    配置路由反射 
neighbor 192.168.1.5 prefix-list zhang out     路由过滤 
no auto-summary 


no ip http server 
no ip http secure-server 

ip prefix-list zhang seq 5 permit 198.0.0.0/8   路由过滤 

control-plane 

gatekeeper 
shutdown 


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 

sanjose3#show run 
Building configuration... 

Current configuration : 1440 bytes 

version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 

hostname sanjose3 

boot-start-marker 
boot-end-marker 


no aaa new-model 


ip cef 
no ip domain lookup 

interface Loopback0 
ip address 198.133.219.1 255.255.255.0 

interface FastEthernet0/0 
no ip address 
shutdown 
duplex half 

interface Serial1/0 
ip address 172.24.1.18 255.255.255.0 
serial restart-delay 0 


router rip 
version 2 
network 172.24.0.0 
no auto-summary 

router bgp 100 
no synchronization 
bgp log-neighbor-changes 
network 198.133.219.0 
aggregate-address 198.0.0.0 255.0.0.0   汇总 
neighbor 172.24.1.17 remote-as 100 
no auto-summary 


no ip http server 
no ip http secure-server 

control-plane 

gatekeeper 
shutdown 


line con 0 
exec-timeout 0 0 
logging synchronous 
stopbits 1 
line aux 0 
stopbits 1 
line vty 0 4 


end 

sanjose2#show ip prot 
Routing Protocol is "rip" 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Sending updates every 30 seconds, next due in 12 seconds 
 Invalid after 180 seconds, hold down 180, flushed after 240 
 Redistributing: rip 
 Default version control: send version 2, receive version 2 
   Interface             Send  Recv  Triggered RIP  Key-chain 
   Serial1/0             2     2                                     
   Serial1/1             2     2                                     
   Loopback0             2     2                                     
 Automatic network summarization is not in effect 
 Maximum path: 4 
 Routing for Networks: 
   10.0.0.0 
   172.24.0.0 
   192.168.1.0 
 Routing Information Sources: 
   Gateway         Distance      Last Update 
 Distance: (default is 120) 

Routing Protocol is "bgp 100" 
 Outgoing update filter list for all interfaces is not set 
 Incoming update filter list for all interfaces is not set 
 Route Reflector for address family IPv4 Unicast, 2 clients 
 Route Reflector for address family IPv6 Unicast, 2 clients 
 Route Reflector for address family VPNv4 Unicast, 2 clients 
 Route Reflector for address family IPv4 Multicast, 2 clients 
 Route Reflector for address family IPv6 Multicast, 2 clients 
 IGP synchronization is disabled 
 Automatic route summarization is disabled 
 Neighbor(s): 
   Address          FiltIn FiltOut DistIn DistOut Weight RouteMap 
   172.24.1.18                                           
   192.168.1.5                                           
 Maximum path: 1 
 Routing Information Sources: 
   Gateway         Distance      Last Update 
   172.24.1.18          200      00:10:16 
 Distance: external 20 internal 200 local 200 


sanjose2#show ip bgp 198.0.0.0 
BGP routing table entry for 198.0.0.0/8, version 5 
Paths: (1 available, best #1, table Default-IP-Routing-Table) 
 Advertised to update-groups: 
    1          2          
 Local, (aggregated by 100 172.24.1.18), (Received from a RR-client) 
   172.24.1.18 from 172.24.1.18 (172.24.1.18) 
     Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best 

sanjose1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP 
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
      E1 - OSPF external type 1, E2 - OSPF external type 2 
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 
      ia - IS-IS inter area, * - candidate default, U - per-user static route 
      o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

    172.24.0.0/24 is subnetted, 1 subnets 
R       172.24.1.0 [120/1] via 192.168.1.6, 00:00:07, Serial1/0 
    10.0.0.0/24 is subnetted, 1 subnets 
R       10.2.2.0 [120/1] via 192.168.1.6, 00:00:07, Serial1/0 
    192.168.1.0/30 is subnetted, 1 subnets 
C       192.168.1.4 is directly connected, Serial1/0 
B    198.0.0.0/8 [200/0] via 172.24.1.18, 00:15:15 


sanjose1#tclsh 
sanjose1(tcl)#foreach address { 
+>10.2.2.1 
+>192.168.1.5 
+>192.168.1.6 
+>172.24.1.17 
+>172.24.1.18 
+>198.133.219.1 
+>} { 
+>ping $address } 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/100 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/78/128 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/35/68 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/41/124 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/39/80 ms 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/33/72 ms








本文转自zhang25yun51CTO博客,原文链接:http://blog.51cto.com/1585654/1402023 ,如需转载请自行联系原作者






相关文章
|
21天前
|
网络协议 Linux
route 或 ip route命令详解
【4月更文挑战第9天】`route`和`ip route`是Linux下管理IP路由的命令,用于查看和配置路由表。`route`命令简单,可查看、添加和删除路由,而`ip route`更现代且功能强大,支持路由可信度和距离设置。`ip route show`类似于`route -n`用于显示路由信息。路由类型包括主机、网络和默认路由。在现代Linux系统中,推荐使用`ip route`。
37 1
|
29天前
|
算法 网络架构
router和route的区别?
router和route的区别?
15 0
|
1月前
|
前端开发 网络架构
浅谈Router和Route
浅谈Router和Route
14 0
|
2月前
|
JavaScript 网络架构
$route和$router的区别
$route和$router的区别
13 0
|
4月前
|
JavaScript Go 网络架构
route和router的区别
route和router的区别
55 0
|
9月前
|
网络架构
$router和$route的区别?
$ router是用来操作路由的,$ route是用来获取路由信息的。
|
6月前
|
前端开发 JavaScript 网络架构
Route和Router的区别
Route和Router的区别
24 0
|
8月前
|
存储 JavaScript 调度
Router和Route
Router和Route
29 0
|
9月前
|
JavaScript
$router和$route区别
$router和$route区别