开发者社区> 科技小能手> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

03-4 BGP 默认路由/MED

简介:
+关注继续查看
Technorati 标签: CCIE,BGP,默认路由,MED,原理

该文档涉及的命令有:

defualt-informatoin originate

default-metric metric

3-4-1 defualt-informatoin originate

用途:允许BGP通告默认路由0.0.0.0。默认路由可以以每个邻居per-neighbor来进行通告。

和ospf的default-informtaion originate用途是一样的.

会通告一个默认路由给其他的邻居,标示自己这里才是internet的出口网关.

在这里,如果要让BGP通告默认路由,下面3个步骤是必不可少的:

1,创建静态默认路由

2,将静态默认路由重分发进bgp进程

3,设置BGP命令default-information originate

clip_image002

R1和R2的配置:

R1配置

interface FastEthernet0/0

ip address 1.1.1.1 255.255.255.0

duplex full

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 1.1.1.2 remote-as 2

no auto-summary

!

R2的配置

interface FastEthernet0/0

ip address 1.1.1.2 255.255.255.0

duplex full

!

interface FastEthernet1/0

ip address 2.1.1.1 255.255.255.0

duplex full

speed auto

!

router bgp 2

no synchronization

bgp log-neighbor-changes

redistribute static

neighbor 1.1.1.1 remote-as 1

default-information originate

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 2.1.1.2

前面已经说过,要让bgp通告默认路由给邻居,必须有的三个必要条件是:

1,创建静态默认路由

2,将静态默认路由重分发进bgp进程

3,设置BGP命令default-information originate

这里,让我们来看看R2上面是否已经通告给R1默认路由指向internet的路由了:

在R2上面:

clip_image004

在R1上面:

clip_image006

最后在R1上面我们已经成功的学习到了R2通告过来的默认路由了。

3-4-2 default-metric [metric]

metric:为经过重分发的路由分配度量值或MED,取值范围为1-4294967295.

有三种方法可以为经过重分发的路由分配度量或者MED:

■当路由被重分发进bgp时,不指定度量值,如果度量值没有被指定,那么经过重分发的路由所分配的度量值为0.这是一个默认行为.但是如果IGP在重分发以前就有metric了,那么重分布以后是0+以前的metric

redistribute ospf 1:ospf路由分配的度量为0.

将另外一种路由协议充分发进bgp为路由分配度量值或者MED.

redistribute ospf 1 metric 5 :ospf偶分配的度量为5.

使用default-metric命令为重分发的路由使用redistribute命令重发布并没有指定度量值的时候),分配度量值或者MED.

redistribute ospf 1 metric 5

redistribute static

default-metric 10: ospf路由分配的度量是5为静态路由重分发进来的度量设置为10.

下面会对这三个属性一一验证:

■当路由被重分发进bgp时,不指定度量值,如果度量值没有被指定,那么经过重分发的路由所分配的度量值为0.这是一个默认行为.

redistribute ospf 1:ospf路由分配的度量为0.但是如果IGP在重分发以前就有metric那么重分布以后是0+以前的metric

clip_image008

这里R2作为AS2的bgp路由器,也是属于ospf 0的IGP部分。

然后在R2上面将ospf重分发到BGP中.最后在R1上面看重分步的10.10.10.10/11.11.11.11的metric.

在R2上面配置为:

clip_image010

最后在R1上面看看metric是多少?

clip_image012

这里重分步进来的metric为2.

那么再在R1上面看看原来igp的metric:

clip_image014

最后对于这种方式,总结一下,从IGP重分发到BGP,并且传递给其他邻居的时候,IGPmetric会携带到BGPMED里面,然后最后不会修改的情况下传递给邻居.

■将另外一种路由协议充分发进bgp时,为路由分配度量值或者MED.

redistribute ospf 1 metric 5 :ospf偶分配的度量为5.

 

 

这次要验证的是在R2上面强制性将ospf1重分发到bgp的路由的metric修改为5传递给R1.

R2的配置:

clip_image016

在R2上面,我们可以看到10.10.10.10/11.11.11.11的metric都是2.

clip_image018

最后在R1上面,所有的metric清一色的修改为了5:

clip_image020



本文转自 hny2000 51CTO博客,原文链接:http://blog.51cto.com/361531/711350

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
干货 | 126 篇 AI 原创文章精选(ML、DL、资源、教程)
干货 | 126 篇 AI 原创文章精选(ML、DL、资源、教程)
46 0
使用 SAP S/4HANA Smart Business Tile 来访问通过 SAP CDS view 暴露出来的 OData 服务
使用 SAP S/4HANA Smart Business Tile 来访问通过 SAP CDS view 暴露出来的 OData 服务
39 0
企业上云之机房和BGP带宽篇(二)
在一些大点儿的城市、二线城市,会有双线、多线机房,其实就是把不同运营商的线路拉到一个机房,托管在这个机房的服务器接上两路线或多路线,这样就在一定程度上解决了前文说的跨网用户访问的速度问题,但又没有完全解决,比如说某条线路断了,怎么办?而且双线会导致服务器有2个IP(这也要求服务器至少是双网卡的),比如,为了让电信的用户访问到服务器的电信IP,这又涉及到使用智能DNS分线路解析,以及DNS解析是否准确的问题,关于智能DNS本篇就不过多说明了。
2179 0
企业上云之机房和BGP带宽篇(一)
本篇是本系列的第二篇,第一篇讲了服务器的种种方面,而与服务器相关性最大的,就是网络。网络把世界上所有网络设备、服务器、个人电脑连接起来,成为了互联网(Internet)。 传统的做法是自购服务器,然后选择一个运营商机房,把服务器放机房里,租用机房的网络,这就叫托管。
2765 0
两台路由连接
你只需把新加入的路由器的LAN地址改成与老路由器地址不同的网段,如老路由器的LAN地址是:192.168.1.1 那就让新加入的路由LAN地址改成192.168.0.1,把DHCP服务关闭, 用一条网线从以前路由的LAN口连接新路由的LAN口,由WAN口空着就可以了,或者不关闭新路由的DHCP服务,用一条网线从以前路由的LAN接到新路的WAN口也可以, 但这样上网可能会慢一些。
427 0
Delphi中的加密算法(MD5,MD4,MD3...)
在Delphi自带的Indy控件中其实是提供了MD2,MD4,MD5对象的,我们可以直接使用它们来完成MD5的签名算法。而不需要再去找其它的DLL或是Pas了。在Uses单元中引用 IdHashMessageDigest 单元,再写如下代码即可以达到MD5的实现。示例代码 procedure TForm1.Button1Click(Sender: TObject);var  MyMD5: T
1157 0
23703
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
低代码开发师(初级)实战教程
立即下载
阿里巴巴DevOps 最佳实践手册
立即下载
冬季实战营第三期:MySQL数据库进阶实战
立即下载