Cisco Router PPPoE-阿里云开发者社区

开发者社区> 科技小先锋> 正文

Cisco Router PPPoE

简介:
+关注继续查看

第一步: 配置路由器连接adsl modem的接口
SZNET001(config)#int fa0/0
SZNET001(config-if)#no ip add
SZNET001(config-if)#pppoe enable
SZNET001(config-if)#pppoe-client dial-pool-number 1 #将fa0/0接口加入到拨号池1
SZNET001(config-if)#no shutdown
SZNET001(config-if)#exit

第二步:配置vpdn虚拟拨号
SZNET001(config)#vpdn enable
SZNET001(config)#vpdn-group 1
SZNET001(config-vpdn)#request-dialin  #配置PPPOE客户端为请求拨号
SZNET001(config-vpdn-req-in)#protocol pppoe
SZNET001(config-vpdn-req-in)#exit

第三步:配置敏感数据流用于触发pppoe拨号
SZNET001(config)#dialer-list 1 protocol ip permit

第四步:配置逻辑拨号接口:
SZNET001(config)#int dialer1 #启用拨号配置1
SZNET001(config-if)#encapsulation ppp
SZNET001(config-if)#ppp authentication pap callin
SZNET001(config-if)#ppp pap sent-username username password 0 password
SZNET001(config-if)#ip address negotiated #配置IP地址为协商方式
SZNET001(config-if)#dialer pool 1 #加入到拨号池1
SZNET001(config-if)#dialer-group 1 #引用拨号兴趣流,用于触发拨号
SZNET001(config-if)#no ip mroute-cache
SZNET001(config-if)#mtu 1492
SZNET001(config-if)#exit
-------------------------------------------------------------
如果PAP验证不行,就用PAP+CHAP验证
ppp authentication pap chap callin
ppp chap hostname username
ppp chap password 0 password
ppp pap sent-username username password 0 password
-------------------------------------------------------------

第五步:配置PAT
SZNET001(config)#int fa0/1
SZNET001(config-if)#ip add 192.168.1.1 255.255.255.0
SZNET001(config-if)#no sh
SZNET001(config-if)#ip nat inside
SZNET001(config-if)#exit
SZNET001(config)#int dialer1
SZNET001(config-if)#ip nat outside
SZNET001(config-if)#exit

第六步:配置敏感数据流
SZNET001(config)#access-list 1 permit 192.168.0.0 0.0.255.255
SZNET001(config)#ip nat inside source list 1 interface dialer1 overload

第七步:配置缺省路由
SZNET001(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

第八步:配置排除地址
SZNET001(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.100

第九步:配置路由器为内部网络主机提供dhcp服务
SZNET001(config)#ip dhcp pool office
SZNET001(dhcp-config)#network 192.168.1.0
SZNET001(dhcp-config)#default-router 192.168.1.1
SZNET001(dhcp-config)#dns-server 202.96.134.133 202.96.128.86 8.8.8.8 4.4.4.4  //DNS
SZNET001(dhcp-config)#netbios-name-server 192.168.1.67 //WINS
SZNET001(dhcp-config)#domain-name abc.com
SZNET001(dhcp-config)#lease 0 2 0  //租期位0天2小时0分



本文转自yangye1985 51CTO博客,原文链接:http://blog.51cto.com/yangye/774226,如需转载请自行联系原作者


版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
8年开发,连登陆接口都写这么烂...
大家学写程序时,第一行代码都是hello world。但是当你开始学习WEB后台技术时,很多人的第一个功能就是写的登录 (小声:别人我不知道,反正
8 0
Docker——容器编排(七)(2)
Docker——容器编排(七)(2)
7 0
冬季实战营第二期
Linux操作系统实战入门
5 0
记一次性能优化,单台 4 核 8G 机器支撑 5 万 QPS
需求描述如下:用户进入首页,从数据库中查询是否有合适的弹窗配置,如果没有,则继续等待下一次请求、如果有合适的配置,则返回给前端。这里开始则有多个条件分支,如果用户点击了弹窗,则记录用户点击,并且在配置的时间内不再返回配置,如果用户未点击,则24小时后继续返回本次配置,如果用户点击了,但是后续没有配置了,则接着等待下一次。
6 0
SpringBoot 集成 WebSocket,实现后台向前端推送信息
在一次项目开发中,使用到了Netty网络应用框架,以及MQTT进行消息数据的收发,这其中需要后台来将获取到的消息主动推送给前端,于是
14 0
再见,微服务
本文翻译自Alexandra Noonan 的 Goodbye Microservices: From 100s of problem children to 1 superstar。
6 0
8年开发,连登陆接口都写这么烂...
大家学写程序时,第一行代码都是hello world。但是当你开始学习WEB后台技术时,很多人的第一个功能就是写的登录 (小声:别人我不知道,反正
5 0
门面模式 与 装饰器模式(3)
门面模式 与 装饰器模式(3)
6 0
6967
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载