ASA防火墙静态PAT端口范围测试

简介:

一.测试拓扑

wKioL1X38T-gdNFLAAB2SFv8Pow785.jpg

二.测试思路

1.分别测试tcp和udp的连续端口PAT

2.再用静态端口转换工具分别将TCP端口和udp端口转换到某个常用端口进行测试

---tcp转换到TCP23,用telnet测试

---udp转换到UDP514,用syslog发送进行测试

 3.为了测试方便,防火墙只设两个区Outside和Inside

---将Inside服务器的TCP1000~2000映射到防火墙Outside口的TCP1000~2000上

---将Inside服务器的UDP1000~2000映射到防火墙Outside口的UPD2000~3000上

4.测试发现如果TCP端口范围与UDP端口范围一样,第二个NAT配置不上,会报如下错误:

 ERROR: NAT unable to reserve ports.

三.基本配置

1.Outside服务器

  IP:202.100.1.8/24

2.防火墙ASA842

interface GigabitEthernet0
nameif Outside
security-level 0
ip address 202.100.1.10 255.255.255.0
!
interface GigabitEthernet1
nameif Inside
security-level 100
ip address 10.1.1.10 255.255.255.0 

3.Intside服务器

  IP:10.1.1.8/24

  GW:10.1.1.10


四.静态PAT端口范围配置

1.定义端口范围对象

object network  Inside_Server
      host 10.1.1.8

object service tcp_ports
      service tcp destination range 1000 2000

object service udp_ports
      service udp destination range 2000 3000

2.配置twice-nat

nat (outside,inside) source static any any destination static interface  Inside_Server service tcp_ports tcp_ports

nat (outside,inside) source static any any destination static interface  Inside_Server service udp_ports udp_ports 

3.配置并应用防火墙策略

access-list Outside extended permit tcp any object Inside_Server range 1000 2000
access-list Outside extended permit udp any object Inside_Server range 2000 3000

access-group Outside in interface Outside 

4.测试验证

---可以用多种方式验证,如果进行静态端口转换嫌麻烦,可以直接抓包验证

wKiom1X371WjYC-zAAKKG3cPRyk111.jpg

wKiom1X375rBWB5FAAi4Hi0gI4M239.jpg





本文转自 碧云天 51CTO博客,原文链接:http://blog.51cto.com/333234/1695049,如需转载请自行联系原作者

相关文章
|
4月前
|
Linux 网络安全
linux端口连通性测试telnet、wget、ssh、curl
linux端口连通性测试telnet、wget、ssh、curl
|
6月前
|
网络协议 Linux 网络安全
Linux测试端口的连通性的四种方法
Linux测试端口的连通性的四种方法
209 0
|
6月前
|
网络协议 安全 Linux
百度搜索:蓝易云【Linux系统下如何在防火墙开放指定端口】
在Linux系统中,防火墙是用于保护计算机安全的重要组成部分。默认情况下,大多数Linux发行版都会自带一个防火墙,如iptables、firewalld等。当我们需要运行特定的应用程序或服务时,需要在防火墙中开放相应的端口。下面就是Linux系统下如何在防火墙开放指定端口的详细步骤。
78 0
|
3月前
|
Linux 网络安全 Nacos
麒麟v10系统,服务连接nacos提示连接不上9848端口是什么问题呢?服务和nacos都在一台机器,防火墙也都关闭了,telnet9848是ok的,但服务启动时就连不上9848。
麒麟v10系统,服务连接nacos提示连接不上9848端口是什么问题呢?服务和nacos都在一台机器,防火墙也都关闭了,telnet9848是ok的,但服务启动时就连不上9848。
132 1
|
4月前
|
Ubuntu Linux 网络安全
linux防火墙开放端口
linux防火墙开放端口
219 0
|
4月前
|
Windows
windows上telnet用法 测试端口号
windows上telnet用法 测试端口号
windows上telnet用法 测试端口号
|
4月前
|
应用服务中间件 网络安全 nginx
docker 映射端口穿透内置防火墙
docker 映射端口穿透内置防火墙
127 0
|
7月前
|
运维 Shell 网络安全
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)(三)
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)(三)
875 0
|
7月前
|
运维 网络协议 网络安全
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)(二)
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)(二)
127 0
|
7月前
|
运维 网络协议 Linux
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)(一)
【运维知识进阶篇】iptables防火墙详解(iptables执行过程+表与链概述+iptables命令参数+配置filter表规则+NAT表实现共享上网、端口转发、IP映射)
588 0