1006.Funny Function

简介: Problem Description Function Fx,yF_{x,y}satisfies: F1,1=F1,2=1F_{1,1}=F_{1,2}=1F1,i=F1,i−1...

Problem Description
Function Fx,ysatisfies:
F1,1=F1,2=1
F1,i=F1,i1+2F1,i2(i>=3)
Fi,j=j+N1k=jFi1,k(i>=2,j>=1)
For given integers N and M,calculate Fm,1 modulo 1e9+7.

Input
There is one integer T in the first line.
The next T lines,each line includes two integers N and M .
1<=T<=10000,1<=N,M<263.

Output
For each given N and M,print the answer in a single line.

Sample Input
2
2 2
3 3
Sample Output
2
33

找规律的数学题,规律当时是找出来了,结果不会算。。
规律是:

n,nans=2(2n1)m13ans=2(2n1)m1+13
//AC: 46MS 1680K
#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;
const LL mod=1e9+7;
LL qpow(LL x,LL n){
    LL ret=1;
    for(;n;n>>=1){
    if(n&1)
        ret=ret*x%mod;
    x=x*x%mod;
    }
    return ret;
}
LL inv(LL x)
{
    return qpow(x,mod-2);
}
int T;
LL n,m;
LL ans;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&n,&m);
        if(n&1)    ans=(qpow(qpow(2,n)-1,m-1)*2%mod+1)*inv(3)%mod;
        else ans=qpow(qpow(2,n)-1,m-1)*2%mod*inv(3)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}
目录
相关文章
|
12月前
|
Linux
error: ‘TASK_INTERRUPTIBLE’ undeclared (first use in this function)
error: ‘TASK_INTERRUPTIBLE’ undeclared (first use in this function)
84 0
|
Linux C++
O_RDONLY/O_NOATIME undeclared (first use in this function
O_RDONLY/O_NOATIME undeclared (first use in this function
143 0
O_RDONLY/O_NOATIME undeclared (first use in this function
error: implicit declaration of function ‘RAND_egd’ [-Werror=implicit-function-declaration]
error: implicit declaration of function ‘RAND_egd’ [-Werror=implicit-function-declaration]
100 0
error: implicit declaration of function ‘read‘ [-Werror,-Wimplicit-function-declaration]
error: implicit declaration of function ‘read‘ [-Werror,-Wimplicit-function-declaration]
192 0
|
Web App开发 JavaScript
$(...).find is not a function
$(...).find is not a function
183 0
成功解决AttributeError: 'GradientBoostingRegressor' object has no attribute 'staged_decision_function'
成功解决AttributeError: 'GradientBoostingRegressor' object has no attribute 'staged_decision_function'

热门文章

最新文章