MAC OS 10.6.8安装wireshark

简介:

我的Mac OS是10.6.8 snow leopard,在wireshark官网下载了OS X 10.6 and later Intel 64-bit .dmg

成功安装。

但是运行的时候wireshark主界面却迟迟不出现,切换到shell下执行wireshark命令,出现如下错误

1、

MacBook-Pro:MacOS $ wireshark

 

2012-07-16 11:46:23.304 defaults[667:903]

The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist

2012-07-16 11:46:23.311 defaults[668:903]

The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist

dyld: Library not loaded: /usr/X11/lib/libfreetype.6.dylib

  Referenced from: /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin

  Reason: Incompatible library version: wireshark-bin requires version 14.0.0 or later, but libfreetype.6.dylib provides version 13.0.0

google了下,找到这么一篇文章--http://azhari.harahap.us/2011/05/wireshark-on-mac-os-incompatible-library-version-wireshark-bin-requires-version-13-0-0-or-later-but-libfreetype-6-dylib-provides-version-10-0-0/

2、安装port

需要用port安装freetype的库,但是发现port又没有安装,到这里去下载了http://distfiles.macports.org/MacPorts/MacPorts-1.9.2-10.6-SnowLeopard.dmg,执行安装时,又提示需要安装xcode,原来xcode是苹果公司向开发人员提供的集成开发环境,用于开发Mac OS X和iOS的应用程序。

没办法,花了一个小时的时间去到这里去下载了个http://adcdownload.apple.com/Developer_Tools/xcode_4.2_for_snow_leopard/xcode_4.2_for_snow_leopard.dmg,悲催的是安装时提示错误,如下

Image

不过幸运的是找了个文章--http://stackoverflow.com/questions/10029270/install-xcode-4-2-for-snow-leopard-fails

只要修改系统的日期为2012年3月26日之前即可,成功安装!

接下来终于可以利用sudo port install 安装freetype了,可安装时提示

3、安装freetype

matoMacBook-Pro:zlib-1.2.6 $ sudo port install freetype

--->  Computing dependencies for freetype

--->  Dependencies to be installed: zlib

--->  Staging zlib into destroot

Error: /opt/local/lib/libz.dylib is not in the destroot. Please clean zlib and try again.

Error: Target org.macports.destroot returned: missing /opt/local/lib/libz.dylib in destroot

Error: Failed to install zlib

Log for zlib is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_zlib/main.log

Error: The following dependencies were not installed: zlib

Error: Status 1 encountered during processing.

To report a bug, see <http://guide.macports.org/#project.tickets>

 

一番google之后,终于让我找到了--http://williamsoo.com/?p=1954&cpage=1#comment-441485

cp /Developer/SDKs/MacOSX10.6.sdk/usr/lib/libz.1.2.3.dylib /opt/local/var/macports/sources/rsync.macports.org/release/ports/archivers/zlib/libz.dylib

然后先单独安装zlib,sudo port install zlib,如果上面那个错误还是出现,可以

sudo port clean --all zlib

再继续

接下来应该就完成了,freetype安装完后,应该就没啥问题了

至此,wireshark就成功安装完毕了!如图,比较难看,不过能用就行啦!

Image





本文转自 taojin1240 51CTO博客,原文链接:http://blog.51cto.com/taotao1240/933040,如需转载请自行联系原作者
目录
相关文章
|
2月前
|
Unix 网络安全 iOS开发
Mac 电脑如何安装Wireshark?
Mac 电脑如何安装Wireshark?
Mac 电脑如何安装Wireshark?
|
13小时前
|
存储 Ubuntu 网络安全
|
9天前
|
Dart Shell 开发工具
解决windows安装Flutter时出现Unknown operating system. Cannot install Dart SDK.问题
解决windows安装Flutter时出现Unknown operating system. Cannot install Dart SDK.问题
|
12天前
|
关系型数据库 MySQL 开发工具
【开发工具专题_02】windows操作系统下载与安装mysql8.0.18教程
【开发工具专题_02】windows操作系统下载与安装mysql8.0.18教程
11 0
|
23天前
|
NoSQL 关系型数据库 MySQL
Windows、Linux、Mac安装数据库(mysql、MongoDB、Redis)#0
不同系统下进行MySQL安装、MongoDB安装、Redis安装【2月更文挑战第5天】
231 5
Windows、Linux、Mac安装数据库(mysql、MongoDB、Redis)#0
|
27天前
|
关系型数据库 MySQL 数据安全/隐私保护
【MySQL】 Docker 安装 MySQL8.0(mac)
【MySQL】 Docker 安装 MySQL8.0(mac)
|
28天前
|
Go
Mac安装Angular并部署运行应用
Mac安装Angular并部署运行应用
|
28天前
|
自然语言处理 搜索推荐 iOS开发
Mac安装和使用GitBook
Mac安装和使用GitBook
|
28天前
mac安装homebrew失败:Failed to connect to raw.githubusercontent.com port 443: Connection refused
mac安装homebrew失败:Failed to connect to raw.githubusercontent.com port 443: Connection refused
|
2月前
|
资源调度 前端开发 JavaScript
Mac电脑如何安装Cypress?
Mac电脑如何安装Cypress?

相关产品

  • 云迁移中心