voip电话解决方案-阿里云开发者社区

开发者社区> 开发与运维> 正文

voip电话解决方案

简介:

目前IP电话方案的设计有以下几种方式:普通语音网关接入方式,路由器接入方式,IP PHONE方式等。

1.普通语音网关接入方式是利用专用的语音网关设备连接语音程控交换机和广域网链路; 
2.路由器接入方式是利用已有的路由器所具有的语音处理功能,实现传统模拟电话与IP网络的连接; 
3.IP PHONE方式是使用软PBX,例如Cisco的Call Manager作为电话的管理中心,利用交换机连接IP电话,实现三网合一的连接模式。

在使用路由器布署IP电话的时候主要应用到以下几种类型语音卡: 
·FXS voice/fax接口卡。FXS的端口提供振铃电流,电压和拨号音。端口为标准的RJ11接头,用普通的电话线就可以直接接电话机。有一种说法通过电话线,FXS卡也可以接到标准模拟交换机的外线接口上(相当于电信局提供的一条外线)。还有一种说法是可以接PBX的中继接口上。 
·FXO voice/fax接口卡。FXO的端口相当于哑终端(电话机),本身无法提供振铃电流,电压和拨号音。端口也为标准的RJ11接口。它可以与PSTN的交换机相连,或者与PBX的标准接口(内线)相连。总之,它必须由对端提供振铃电流,电压和拨号音。 
·E/M voice/fax接口卡。E/M是一种交换机的接口标准。E/M卡主要用来与交换机上干线上的E/M口连接。 
·E1接口卡主要用来与交换机上的E1接口卡相连接,一路E1可以同时提供30路语音通话。

路由器的IOS软件需要是IP Plus特性的。

可以采用专门的AS5300 or AS5800语音接入网关,考虑到目前和以后企业IP电话的扩展可能性和最大通话连接数,决定还是利用原有设备增加语音模块的方案布署VoIP电话系统。

总部:Cisco3662:原有2块WIC-2T。增加NM-2V 2块、WIC-2FXO 4块

两分部:Cisco2621: 原有1块WIC-1T。增加NM-2V 1块、WIC-2FXS 1块

设计拓扑:

|------------------------{PBX}------A]

|

|fxo

(北京)1.1.1.1-----1.1.1.2 (上海)-- fxs -- B]

| 1.1.2.1

|

|-----------------1.1.2.2 (深圳) -- fxs --C]

北京路由器配置:

interface FastEthernet0/0 
ip address 10.10.0.1 255.255.255.0 
!  
interface Serial3/0 
ip address 1.1.1.1 255.255.255.252 
!  
interface Serial3/1 
ip address 1.1.2.1 255.255.255.252 

voice-port 1/0/0 
voice-port 1/0/1 

dial-peer voice 1 pots 
destination-pattern 0 
port 1/0/0 

dial-peer voice 2 pots 
destination-pattern 0 
port 1/0/1 

dial-peer voice 10 voip 
destination-pattern 100 
session target ipv4:1.1.1.2 

dial-peer voice 20 voip 
destination-pattern 200 
session target ipv4:1.1.2.2 

router ospf 100 
log-adjacency-changes 
network 1.1.0.0 0.0.255.255 area 1 
network 10.10.0.0 0.0.255.255 area 1

上海配置:

interface FastEthernet0/0 
ip address 10.10.1.1 255.255.255.0 

interface Serial0/0 
ip address 1.1.1.2 255.255.255.252 

voice-port 1/0/0 
voice-port 1/0/1 

dial-peer voice 1 pots                   
destination-pattern 100                
port 1/0/0                             

dial-peer voice 2 pots 
destination-pattern 101 
port 1/0/1 

dial-peer voice 3 voip 
destination-pattern 0 
session target ipv4:1.1.1.1 

dial-peer voice 4 voip 
destination-pattern 2.. 
session target ipv4:1.1.2.2 

router ospf 100 
network 1.1.0.0 0.0.255.255 area 1 
network 10.10.0.0 0.0.255.255 area 1 
!

深圳配置

interface FastEthernet0/0 
ip address 10.10.2.1 255.255.255.0 

interface Serial0/0 
ip address 1.1.2.2 255.255.255.252 

voice-port 1/0/0 
voice-port 1/0/1 

dial-peer voice 1 pots                    
destination-pattern 200                 
port 1/0/0                               

dial-peer voice 2 pots 
destination-pattern 201 
port 1/0/1 

dial-peer voice 3 voip 
destination-pattern 0 
session target ipv4:1.1.1.1 

dial-peer voice 4 voip 
destination-pattern 1.. 
session target ipv4:1.1.1.2 

router ospf 100 
network 1.1.0.0 0.0.255.255 area 1 
network 10.10.0.0 0.0.255.255 area 1 
!

到此所有配置均配置完毕,在北京总部拿起电话A先拔FXO在PBX接口上的分机号888,出现提示音,然后拔上海的电话号100,此时上海的电话B响起。接起即可以通话了,听一听,音质还不错。

从B拔C,也可以通话,通话质量均还可以。

从B和C拔A也能拔通。

在VoIP系统中存在几个拔号的段,第一段是模拟电话到PBX的呼叫段,第二段PBX到路由器上fxo模块的呼叫段,第三段为路由器到到路由器,第四段为路由器上fxs到电话的呼叫段。

在中心路由器上增加了如下配置:

voice-port 1/0/0 
cptone CN 
timeouts call-disconnect 0 
timeouts ringing 5 
timeouts wait-release 1

整理下配置资料:

dial-peer voice 1 pots             ******建立拔号对等体1 
destination-pattern 0             ******设置号码为0, 有多个号码在0后面加相应的点号即可,如0… 
port 1/0/0                        ******和语音端口绑定

dial-peer voice 10 voip            ******建立VoIP拔号对等体10 
destination-pattern 100           ******设置拔号号码为100 
session target ipv4:1.1.1.2       ******设置VoIP对体等对应的IP网关

voice-port 1/0/0 ******进入语音接口1/0/0配置模式 
cptone CN ******设置区域 
timeouts call-disconnect 0       ******设置呼叫无应答挂断时间 
timeouts ringing 5            ******设置振铃时间 
timeouts wait-release 1          ******设置等待释放时间



本文转自 gehailong 51CTO博客,原文链接:http://blog.51cto.com/gehailong/297454,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章