Poj 1611 The Suspects

简介:

Poj 1611 的传送门

              ***The Suspects***

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

题目大意:第一行为两个整数n和m, 其中n是学生的数量, m是团体的数量。0 < n <= 30000,0 <= m <= 500。
每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。
紧随其后的是团体的成员列表,每组一行。
每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。
n = m = 0表示输入结束,不需要处理。
然后输出可能感染的人的个数

解题思路:并查集:

具体详见代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 30010;

int fa[maxn];//父亲节点
int rank[maxn];//rank[x]就是表示x的高度上的一个上界
int sum[maxn];//sum[]存储该集合中元素个数,并在集合合并时更新sum[]即可
void Init(int x)//创建单元集
{
    fa[x]=x;
    sum[x]=1;
    rank[x]=0;
    return ;
}

int Find(int x)//递归找父亲,路径压缩
{
    if(x != fa[x])
        fa[x]=Find(fa[x]);
    return fa[x];
}

void Union(int a, int b)//让rank比较高的作为父亲节点
{
    a=Find(a);
    b=Find(b);
    if(a == b)
        return ;
    if(rank[a] > rank[b])
    {
        fa[b]=a;
        sum[a]+=sum[b];
    }
    else
    {
        fa[a]=b;
        if(rank[a] == rank[b])
            rank[b]++;
        sum[b]+=sum[a];
    }
}
int main()
{
    int m,n,k,a,b;
    while(cin>>m>>n)
    {
        if(!m && !n)
            break;
        if(n == 0)
        {
            puts("1");
            continue;
        }
        for(int i=0; i<m; i++)
            Init(i);
        while(n--)
        {
            cin>>k>>a;
            k--;
            while(k--)
            {
                cin>>b;
                Union(a, b);
            }
        }
        cout<<sum[Find(0)]<<endl;
    }
    return 0;
}
目录
相关文章
|
9月前
|
算法
Highways(POJ—2485)
Highways(POJ—2485)
|
算法框架/工具
POJ 2262 Goldbach's Conjecture
POJ 2262 Goldbach's Conjecture
150 0
|
人工智能 算法 BI
poj 2192 Zipper
题目链接:http://poj.org/problem?id=2192 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 18658   Accepted: 6651 Description Given ...
987 0
|
测试技术
POJ 1001
此题用最朴素的思路实现即可,需模拟加法器,乘法器,最烦人的地方是特殊情形,如末位是小数点(12.^2=144,取小数点),整数末位是0(100^2=10000),0次幂,测试用例可能超出题目中说的范围,可能包含0次幂(100.0^0=0, 0.10^1=0.1)。
763 0
|
测试技术
poj-1218 THE DRUNK JAILER 喝醉的狱卒
自己去看看原题; 题目大意: 就是一个狱卒喝醉了,他第一趟吧所有的监狱都带开,第二趟把能把二整除的监狱关闭,第三趟操作能把三整除的监狱; 求最后能逃跑的罪犯数 输入第一个数是代表 测试数据组数 每个数据代表狱卒来回的次数 当作开关问题即可 #include using names...
1024 0
|
机器学习/深度学习