hdu 5491 The Next(ICPC合肥赛)

简介:

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 808    Accepted Submission(s): 316


Problem Description
Let  L denote the number of 1s in integer  D’s binary representation. Given two integers  S1 and  S2, we call  D a WYH number if  S1LS2.
With a given  D, we would like to find the next WYH number  Y, which is JUST larger than  D. In other words,  Y is the smallest WYH number among the numbers larger than  D. Please write a program to solve this problem.
 

Input
The first line of input contains a number  T indicating the number of test cases ( T300000).
Each test case consists of three integers  D S1, and  S2, as described above. It is guaranteed that  0D<231 and  D is a WYH number.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X is the test case number starting from 1.  Y is the next WYH number.
 

Sample Input
 
 
3 11 2 4 22 3 3 15 2 5
 

Sample Output
 
 
Case #1: 12 Case #2: 25 Case #3: 17
 

Source


题目大意:
就是给定一个数d,让你求二进制数中1的个数>=s1同时<=s2中的数

解题思路:
首先得到这个数二进制中1的个数,然后让这个数+1,判断当d>s2 和<s1的情况,因为找的是最小值,
所以,只需要当<s1的时候将二进制中0的个数变为1
>s1的时候,将二进制中1的个数变为0

上代码:
/**
2015 - 09 - 22 下午


Author: ITAK


Motto:


今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 10000+5;
const int mod = 1000000007;
const double eps = 1e-7;

bool arr[35];
LL t;
///得到1的个数
LL get_1(LL x)
{
    LL sum = 0;
    t = 0;
    while(x)
    {
        arr[t++] = x%2;
        if(x&1)
            sum++;
        x>>=1;
    }
    return sum;
}
int main()
{
    LL d, s1, s2, T;
    scanf("%lld",&T);
    for(LL cas=1; cas<=T; cas++)
    {
        scanf("%lld%lld%lld",&d,&s1,&s2);
        MM(arr);
        t = 0;
        d++;
        while(1)
        {
            LL ans = get_1(d);
            if(ans < s1)
            {
                for(int i=0; i<t; i++)
                    if(!arr[i])
                    {
                        d += 1<<i;
                        break;
                    }
            }
            else if(ans > s2)
            {
                for(int i=0; i<t; i++)
                    if(arr[i])
                    {
                        d += 1<<i;
                        break;
                    }
            }
            else
                break;
        }
        printf("Case #%lld: %lld\n",cas,d);
    }
    return 0;
}




目录
相关文章
|
8月前
2017ICPC沈阳区域赛 F
2017ICPC沈阳区域赛 F
45 0
|
SQL 数据安全/隐私保护 Python
湖北省工匠杯预赛WriteUP
湖北省工匠杯预赛WriteUP
135 0
|
PHP
[SWPUCTF 2021 新生赛]babyrce
[SWPUCTF 2021 新生赛]babyrce
299 0
|
C++
山东省第一届省赛 Ivan comes again
山东省第一届省赛 Ivan comes again
70 0
桂林电子科技大学第三届ACM程序设计竞赛 B题
桂林电子科技大学第三届ACM程序设计竞赛 B题
85 0
桂林电子科技大学第三届ACM程序设计竞赛 D题
桂林电子科技大学第三届ACM程序设计竞赛 D题
109 0
桂林电子科技大学第三届ACM程序设计竞赛 E题
桂林电子科技大学第三届ACM程序设计竞赛 E题
78 0
桂林电子科技大学第三届ACM程序设计竞赛 J题
桂林电子科技大学第三届ACM程序设计竞赛 J题
94 0
桂林电子科技大学第三届ACM程序设计竞赛 I题
桂林电子科技大学第三届ACM程序设计竞赛 I题
89 0
桂林电子科技大学第三届ACM程序设计竞赛 F题
桂林电子科技大学第三届ACM程序设计竞赛 F题
93 0