POJ-2406-Power Strings

简介: POJ-2406-Power Strings







Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 96   Accepted Submission(s) : 34

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

 


Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

 


Output

For each s you should print the largest n such that s = a^n for some string a.

 


Sample Input

abcd aaaa ababab .

 


Sample Output

1 4 3



题目分析:

意思是有多少个子串构成比如说  aaaa = a^4   ababab=(ab)^3    abcd=(abcd)^1    应该明白了吧!也就是这个字符串能被他的最短子串构成   由kmp ,next表的特点知如果满足  len%(len-p[len])==0  就能由子串构成且子串个数就是 len/(len-p[len])



#include<cstdio>
#include<cstring>
const int M = 1000000+10;
char str[M];
int p[M],a[M],len;
void getp()
{
  int i=0,j=-1;
  p[i]=j;
  while(i<len)
  {
    if(j==-1||str[i]==str[j])
    {
      i++;j++;
      p[i]=j;
    }
    else j=p[j];
  }
}
int main()
{
  while(~scanf("%s",str)&&str[0]!='.')
  {
    len=strlen(str);
    getp();
                if(len%(len-p[len])==0)
      printf("%d\n",len/(len-p[len]));
    else
      printf("1\n");
  }
  return 0;
}















目录
相关文章
|
1月前
|
C++ 容器
POJ3096—Surprising Strings
POJ3096—Surprising Strings
LeetCode 342. Power of Four
给定一个整数 (32 位有符号整数),请编写一个函数来判断它是否是 4 的幂次方。
62 0
LeetCode 342. Power of Four
|
人工智能 BI
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
64 0
|
Java C++
LeetCode之Power of Two
LeetCode之Power of Two
98 0
|
Java
2017 Multi-University Training Contest - Team 1 1002&&HDU 6034 Balala Power!【字符串,贪心+排序】
Balala Power! Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 2668    Accepted Submission(s...
1250 0
|
Java
[LeetCode]--326. Power of Three
Given an integer, write a function to determine if it is a power of three. Follow up: Could you do it without using any loop / recursion? Credits: Special thanks to @dietpepsi for addin
1099 0
|
Java
[LeetCode]--342. Power of Four
Given an integer (signed 32 bits), write a function to check whether it is a power of 4. Example: Given num = 16, return true. Given num = 5, return false. Follow up: Could you solve it
1145 0