POJ-2406-Power Strings

简介: POJ-2406-Power Strings







Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 96   Accepted Submission(s) : 34

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

 


Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

 


Output

For each s you should print the largest n such that s = a^n for some string a.

 


Sample Input

abcd aaaa ababab .

 


Sample Output

1 4 3



题目分析:

意思是有多少个子串构成比如说  aaaa = a^4   ababab=(ab)^3    abcd=(abcd)^1    应该明白了吧!也就是这个字符串能被他的最短子串构成   由kmp ,next表的特点知如果满足  len%(len-p[len])==0  就能由子串构成且子串个数就是 len/(len-p[len])



#include<cstdio>
#include<cstring>
const int M = 1000000+10;
char str[M];
int p[M],a[M],len;
void getp()
{
  int i=0,j=-1;
  p[i]=j;
  while(i<len)
  {
    if(j==-1||str[i]==str[j])
    {
      i++;j++;
      p[i]=j;
    }
    else j=p[j];
  }
}
int main()
{
  while(~scanf("%s",str)&&str[0]!='.')
  {
    len=strlen(str);
    getp();
                if(len%(len-p[len])==0)
      printf("%d\n",len/(len-p[len]));
    else
      printf("1\n");
  }
  return 0;
}















目录
相关文章
|
8月前
|
C++ 容器
POJ3096—Surprising Strings
POJ3096—Surprising Strings
|
算法
light oj 1255 - Substring Frequency (KMP)
输入两个字符串,计算二串在一串中出现的次数。 裸裸的KMP,参考刘汝佳《算法竞赛入门经典训练指南》 P212 或数据结构。
35 1
|
人工智能 BI
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
CodeForces - 1485D Multiples and Power Differences (构造+lcm)
90 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
244 0
|
存储
HDOJ/HDU 1073 Online Judge(字符串处理~)
HDOJ/HDU 1073 Online Judge(字符串处理~)
106 0
|
Java C++
LeetCode之Power of Two
LeetCode之Power of Two
120 0
Gym 100952D&&2015 HIAST Collegiate Programming Contest D. Time to go back【杨辉三角预处理,组合数,dp】
D. Time to go back time limit per test:1 second memory limit per test:256 megabytes input:standard input output:standard output ...
1146 0
|
Java C++
HDU 1004 Let the Balloon Rise【STL<map>】
Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 123800    Accepted Submi...
1535 0