macOS10.13.6及以下版本不能自动升级到更高版本的解决方案

简介: macOS10.13.6及以下版本不能自动升级到更高版本的解决方案

我习惯了在App Store自动升级macOS、XCode、苹果手机iOS系统升级。最近我升级了我的iphone xr到iOS 12.2版本。真机调试时,提示需要XCode升级到10.2版本才能使用。

我打开App Store发现操作系统是10.13.6,已经是‘最高版本’,无法升级了。下面有一个不兼容的升级,点击看到XCode升级。最后点击升级后显示以下错误:

那为何App Store不能升级macOS到10.14.3呢?最近很多网站在传iOS13以后不支持iPhone7以下的手机,所以就想想可能苹果抛弃了我们。我的电脑才买两年,还不到三年,不会就这么逼着我们换电脑吧!

在网上查了下,macOS Mojave支持的产品是:

支持我的MacBook Air (13-inch, Early 2015),那为何不能自动升级呢?

在苹果商店查找的到macOS Mojave的升级连接

然后点击在这里查看: Mac App Store 跳转到Mac App Store ,看到macOS Mojave,点击获取就是漫长的等待下载完成后升级。macOS升级到10.14.4后,然后就在Mac App Store搜索XCode点击获取,升级到10.2.1。

升级完成后发现Mac App Store大变样。

估计是老的Mac App Store不支持macOS10.13.6升级到最新的macOS Mojave,就是Mac App Store升级工具的问题。看来自动的并不完全靠谱,有时间也会摆乌龙,多去网上查一查,手机升级也是需要会的!


注意:若在App Store搜不到macos monterey可能说明你的电脑不在macos monterey系统支持电脑型号中。可以去官网查看新的操作系统支持电脑型号。


目录
相关文章
|
iOS开发 MacOS
如何升级MacOS到指定版本
如何升级MacOS到指定版本
504 0
|
安全 iOS开发 MacOS
【解决方案】MacOS遇到“无法打开xxx,因为Apple无法检查其是否包含恶意软件”,怎么处理。
【解决方案】MacOS遇到“无法打开xxx,因为Apple无法检查其是否包含恶意软件”,怎么处理。
1097 0
【解决方案】MacOS遇到“无法打开xxx,因为Apple无法检查其是否包含恶意软件”,怎么处理。
|
开发工具 iOS开发 git
【技术分享】MacOS环境Could not resolve proxy: “localhost:1080“解决方案
【技术分享】MacOS环境Could not resolve proxy: “localhost:1080“解决方案
280 0
【技术分享】MacOS环境Could not resolve proxy: “localhost:1080“解决方案
|
数据安全/隐私保护 iOS开发 MacOS
【解决方案】MacOS遇到“xxx”已损坏,无法打开。您应该将它移到废纸篓……
【解决方案】MacOS遇到“xxx”已损坏,无法打开。您应该将它移到废纸篓……
510 0
【解决方案】MacOS遇到“xxx”已损坏,无法打开。您应该将它移到废纸篓……
|
安全 Shell iOS开发
Mac OSX(Mac OS10.11) 安装 pwntools 失败的最新解决方案
Mac OSX(Mac OS10.11) 安装 pwntools 失败的最新解决方案
382 0
|
iOS开发 MacOS
macOS下JetBrains配置修改错误导致无法启动解决方案
macOS下JetBrains配置修改错误导致无法启动解决方案
|
iOS开发 MacOS Python
在MacOS下Python安装lxml报错xmlversion.h not found 报错的解决方案
最近在看一个自动化测试框架的问题,需要用到Lxml库,下载lxml总是报错。 1,使用pip安装lxml pip install lxml 2,然后报错了,报错内容是: In file included from src/lxml/lxml.
1688 0
|
iOS开发 MacOS
macOS 从睡眠中恢复出来之后没有声音的解决方案
打开Active Monitor, 找到coreaudiod进程, 将其quit掉即可
928 0
|
算法 C语言 C++
mac OS 安装XGBoost(完美解决方案)
XGBoost是一种基于决策树(CART)的分布式的高效的梯度提升算法,它可被应用到分类、回归、排序等任务中,与一般的GBDT算法相比,XGBoost主要有以下几个优点: 对叶节点的权重进行了惩罚,相当于添加了正则项,防止过拟合 XGBoost的目标...
2604 0
|
Shell iOS开发 Ruby
macOS Ruby版本需要升级到2.2.2以上
在安装 Ruby on Rails 时遇到问题,提示依赖 ruby 2.2.2 或更高的版本。 ERROR: Error installing rails: activesupport requires Ruby version >= 2.
1067 0