node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题

简介: node node-sass sass-loader版本对应问题,对于npm编译大家经常遇到这个问题

更多ruoyi-nbcio功能请看演示系统

gitee源代码地址

前后端代码: https://gitee.com/nbacheng/ruoyi-nbcio

演示地址:RuoYi-Nbcio后台管理系统

1.查看本地node版本

node -v

具体对应版本如下图:

具体对应链接地址:

node-sass

2.查看项目中package中node-sass和sass-loader是否对应node版本

可以用npm list看安装的是什么版本如:

3.不对应应修改成对应版本号

以下是部分版本号对应,具体可百度

sass-loader 4.1.1,node-sass 4.3.0

sass-loader 7.0.3,node-sass 4.7.2

sass-loader 7.3.1,node-sass 4.7.2

sass-loader 7.3.1,node-sass 4.14.1

sass-loader 10.0.1,node-sass 6.0.1

4.如果node是最新版本,则可以直接使用以下命令安装即可

npm install sass-loader node-sass --save-dev

cnpm install sass-loader node-sass --save-dev

5.如果node不是最新版本,则需要安装对应的版本号才行

npm install sass-loader@版本号 node-sass@版本号 --save-dev //安装对应的版本

cnpm install sass-loader@版本号 node-sass@版本号 --save-dev //安装对应的版本

相关文章
|
1月前
|
JavaScript
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
npm install没问题,但npm run dev的时候报Node Sass version 6.0.1 is incompatible with ^4.0.0 ^5.0.0
22 0
|
20天前
|
前端开发
windows10 安装node npm 等前端环境 并配置国内源
windows10 安装node npm 等前端环境 并配置国内源
40 3
|
1月前
【Node】Mac多版本Node切换
【Node】Mac多版本Node切换
43 1
|
1月前
|
资源调度 jenkins 持续交付
jenkins 自动安装nodejs16.16.0版本报错处理
jenkins 自动安装nodejs16.16.0版本报错处理
78 0
|
1月前
|
JavaScript Unix Shell
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
#! /usr/bin/env node 命令与 npm link 建立项目间软连接(一)
31 0
|
程序员 编译器
解决 Angular 官网下载的库 Schematics 执行 npm run build 时遇到的编译错误
解决 Angular 官网下载的库 Schematics 执行 npm run build 时遇到的编译错误
163 0
解决 Angular 官网下载的库 Schematics 执行 npm run build 时遇到的编译错误
|
1月前
|
网络安全 计算机视觉
【node】 npm install 报错:code 128
【node】 npm install 报错:code 128
58 1
|
1月前
|
JavaScript Linux 数据安全/隐私保护
node内网安装npm私服以及依赖包上传发布verdaccio
node内网安装npm私服以及依赖包上传发布verdaccio
206 1
|
1月前
|
JavaScript 内存技术
node与npm版本对应关系以及使用nvm管理node版本
node与npm版本对应关系以及使用nvm管理node版本
966 0
|
1月前
|
JavaScript
node.js 项目中执行 npm install 命令后看到的 idealTree inflate 的含义
node.js 项目中执行 npm install 命令后看到的 idealTree inflate 的含义

推荐镜像

更多