hdu 1164 Eddy's research I

简介: hdu 1164 Eddy's research I

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12751    Accepted Submission(s): 7866


 

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

 

 

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

 

 

Output

You have to print a line in the output for each entry with the answer to the previous question.

 

 

Sample Input

 

11 9412

 

 

Sample Output

 

11 2*2*13*181

 

 

Author

eddy

 

 

代码:

#include<stdio.h>
int main()
{
    int n,f[65536]={0},F[65536],i,j,k=0;
for(i=2;i<65536;i++)
{
if(f[i]==0)
{
F[k]=i;
k++;
for(j=2;j*i<65536;j++)
f[j*i]=1;
}
}
while(scanf("%d",&n)!=EOF)
{
int t=0;
for(i=0;i<k;i++)
{
while(n%F[i]==0)
{
if(t==1) printf("*");
printf("%d",F[i]);
t=1;
n/=F[i];
}
if(n==1) break;
}
printf("\n");
}
return 0;
}
目录
相关文章
|
4月前
|
人工智能 Java
hdu 1165 Eddy's research II
hdu 1165 Eddy's research II
29 0
|
10月前
|
Java
hdu 1164 Eddy's research I
hdu 1164 Eddy's research I
37 0
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
84 0
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
|
人工智能
upc 2021秋组队训练赛第三场 2020 Rocky Mountain Regional Contest
upc 2021秋组队训练赛第三场 2020 Rocky Mountain Regional Contest
88 0
HDU-1057,A New Growth Industry(理解题意)
HDU-1057,A New Growth Industry(理解题意)
The Famous ICPC Team Again
题目描述 When Mr. B, Mr. G and Mr. M were preparing for the 2012 ACM-ICPC World Final Contest, Mr. B had collected a large set of contest problems for their daily training. When they decided to take training, Mr. B would choose one of them from the problem set.
95 0
Mad Scientist (纯模拟题)
Mad Scientist 题目描述 Farmer John’s cousin Ben happens to be a mad scientist. Normally, this creates a good bit of friction at family gatherings, but it can occasionally be helpful, especially when Farmer John finds himself facing unique and unusual problems with his cows.
134 0
|
人工智能 Java BI
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem D. Team Name
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem D. Team Name
126 0