华为交换机Trunk配置

简介: 华为交换机Trunk配置

华为交换机Trunk配置


Trunk


采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继链路上进行传输前,会先打上一个标记,表明该数据包是Vlan2的,到达对方交换机时,交换机会将该标记去掉,只发送到属于Vlan2的端口上。


例:以下拓扑图中,子网掩码都为255.255.255.0


Vlan1:


左:192.168.1.1   192.168.1.2


右:192.168.1.3   192.168.1.4


Vlan2:


左:192.168.:2.1   192.168.2.2


右:192.168.2.3   192.168.2.4


Vlan3:


左:192.168.3.1   192.168.3.2


右:192.168.3.3   192.168.3.4

3.pngS3700-LSW1

<Huawei>system-view
[Huawei]interface Eth0/0/7
[Huawei-Ethernet0/0/7]port link-type trunk
[Huawei-Ethernet0/0/7]port trunk allow-pass vlan all
[Huawei]display current-configuration
#
interface Ethernet0/0/1
 port link-type access
#
interface Ethernet0/0/2
 port link-type access
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/5
 port link-type access
 port default vlan 3
#
interface Ethernet0/0/6
 port link-type access
 port default vlan 3
#
interface Ethernet0/0/7
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

S3700-LSW2

<Huawei>system-view
[Huawei]interface Eth0/0/3
[Huawei-Ethernet0/0/3]port link-type trunk
[Huawei-Ethernet0/0/3]port trunk allow-pass vlan all
[Huawei]display current-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 2
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/4
 port link-type access
#
interface Ethernet0/0/5
 port link-type access
#
interface Ethernet0/0/6
 port link-type access
 port default vlan 3
#
interface Ethernet0/0/7
 port link-type access
 port default vlan 3

测试

4.png5.png6.png

不同交换机同网段Vlan之间能够互相ping通,说明两个交换机接口配置的Trunk中继链路技术实现成功。

相关文章
|
8月前
交换机的基本原理与配置(三)
交换机的基本原理与配置(三)
166 0
|
7月前
|
网络架构
交换机与路由器技术-24-OSPF单区域配置
交换机与路由器技术-24-OSPF单区域配置
42 0
|
7月前
|
网络架构
交换机与路由器技术-17-生成树协议配置
交换机与路由器技术-17-生成树协议配置
30 0
|
7月前
|
网络架构
交换机与路由器技术-14-三层交换机配置
交换机与路由器技术-14-三层交换机配置
36 0
|
7月前
|
网络架构
交换机与路由器技术-11-VLAN Trunk
交换机与路由器技术-11-VLAN Trunk
35 0
|
7月前
|
网络架构
交换机与路由器技术-08-路由器上配置DHCP
交换机与路由器技术-08-路由器上配置DHCP
20 0
|
7月前
|
网络架构
交换机与路由器技术-07-静态路由配置
交换机与路由器技术-07-静态路由配置
30 0
|
8月前
|
存储 网络安全
交换机的基本原理与配置(二)
交换机的基本原理与配置(二)
107 0
|
8月前
|
算法 数据安全/隐私保护 网络架构
交换机的基本原理与配置(一)
交换机的基本原理与配置(一)
158 0
|
8月前
|
网络安全 数据安全/隐私保护
华为交换机基本配置之Telnet和SSH方式远程登录
华为交换机基本配置之Telnet和SSH方式远程登录
1120 0