IDEA使用笔记-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

IDEA使用笔记

简介: IDEA工具错误记录和解决方法

1.Intellij idea 出现错误 error:java: 无效的源发行版: 8
原因:这是由于jdk的版本与项目的要求不一致造成的,如果你安装的是JDK1.7,而在file->project structure中设置的是language level是8的话,就会出现这个错误提示
将语言级别改为7,或6。即语言级别不能高于你安装的版本
image
另外,如果file -> settings -> build,exception,deployment -> compiler -> java compiler 中如果将模块的target bytecode version改为1.8,则会出现这个错误提示
应改为小于等于安装的版本号
image
2.project sdk is not defined idea
点击Setup SDK,出现设置对话框:添加或选择jdk
也可以在file->project structure中设置project SDK
image

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章