【DHCP实验】使用三层交换机配置DHCP Server服务器(基于全局地址池配置)

简介: 【DHCP实验】使用三层交换机配置DHCP Server服务器(基于全局地址池配置)

一、实验拓扑

f04acda16878410fb343d8b481aee0a5.png

二、实验要求

三层交换机S1通过DHCP的公有地址池给PC1和PC2分配IP地址,PC1属于vlan30,PC2属于vlan40,具体要求如下:

(1) 更改主机名S1

(2) 创建vlan 30 40

(3) 配置vlanif 30接口的IP地址为192.168.30.254,vlanif 40接口的IP地址为192.168.40.254

(4) 配置access接口

(5) 启用DHCP

(6) 配置全局地址池

地址池1名:dhcp_vlan30

地址网段:192.168.30.0/24

网关:192.168.30.254

DNS服务器地址:114.114.114.114和 8.8.8.8

地址池2名:dhcp_vlan40

地址网段:192.168.40.0/24

网关:192.168.40.254

DNS服务器地址:114.114.114.114和 8.8.8.8

(7) 配置vlanif 30和vlanif40虚接口下启用全局地址池


三、实验步骤

(1) 更改主机名S1
The device is running!
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.  
[Huawei]undo info-center enable 
Info: Information center is disabled. 
[Huawei]sysname S1
[S1]
(2) 创建vlan 30 40
[S1]vlan batch 30 40
Info: This operation may take a few seconds. Please wait for a moment...done.
[S1]
(3) 配置vlanif 30接口的IP地址为192.168.30.254,vlanif 40接口的IP地址为192.168.40.254
!!!注意配置接口IP地址与配置端口access时的先后顺序,应先创建并配置vlan以及接口IP地址,再将各个端口加入相应的vlan中,否则vlan端口启动不了!!!
[S1]interface Vlanif 30
[S1-Vlanif30]ip address 192.168.30.254 24
[S1-Vlanif30]display this
#
interface Vlanif30
 ip address 192.168.30.254 255.255.255.0
#
return
[S1-Vlanif30]quit 
[S1]interface Vlanif 40
[S1-Vlanif40]ip address 192.168.40.254 24
[S1-Vlanif40]display this
#
interface Vlanif40
 ip address 192.168.40.254 255.255.255.0
#
return
[S1-Vlanif40]quit 
[S1]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 3
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 4
Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           up         down      
Vlanif30                          192.168.30.254/24    down       down      
Vlanif40                          192.168.40.254/24    down       down      
[S1]
(4) 配置access接口
[S1]interface GigabitEthernet 0/0/1
[S1-GigabitEthernet0/0/1]port link-type access    
[S1-GigabitEthernet0/0/1]port default vlan 30
[S1-GigabitEthernet0/0/1]display this
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 30
#
return
[S1-GigabitEthernet0/0/1]quit
[S1]interface GigabitEthernet 0/0/3
[S1-GigabitEthernet0/0/3]port link-type access  
[S1-GigabitEthernet0/0/3]port default vlan 40
[S1-GigabitEthernet0/0/3]display this
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 40
#
return
[S1-GigabitEthernet0/0/3]quit
[S1]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 3
The number of interface that is DOWN in Protocol is 2
Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           down       down      
Vlanif30                          192.168.30.254/24    up         up        
Vlanif40                          192.168.40.254/24    up         up        
[S1]
(5) 启用DHCP
[S1]dhcp enable 
[S1]
(6) 配置全局地址池
     地址池1名:dhcp_vlan30
     地址网段:192.168.30.0/24
     网关:192.168.30.254
     DNS服务器地址:114.114.114.114和 8.8.8.8
     地址池2名:dhcp_vlan40
     地址网段:192.168.40.0/24
     网关:192.168.40.254
     DNS服务器地址:114.114.114.114和 8.8.8.8
[S1]ip pool dhcp_vlan30
Info:It's successful to create an IP address pool.  
[S1-ip-pool-dhcp_vlan30]network 192.168.30.0 mask 24  
[S1-ip-pool-dhcp_vlan30]gateway-list 192.168.30.254 
[S1-ip-pool-dhcp_vlan30]dns-list 114.114.114.114 8.8.8.8
[S1-ip-pool-dhcp_vlan30]display this
#
ip pool dhcp_vlan30
 gateway-list 192.168.30.254
 network 192.168.30.0 mask 255.255.255.0
 dns-list 114.114.114.114 8.8.8.8
#
return
[S1-ip-pool-dhcp_vlan30]quit
[S1]ip pool dhcp_vlan40
Info:It's successful to create an IP address pool.
[S1-ip-pool-dhcp_vlan40]network 192.168.40.0 mask 24
[S1-ip-pool-dhcp_vlan40]gateway-list 192.168.40.254
[S1-ip-pool-dhcp_vlan40]dns-list 114.114.114.114 8.8.8.8
[S1-ip-pool-dhcp_vlan40]display this
#
ip pool dhcp_vlan40
 gateway-list 192.168.40.254
 network 192.168.40.0 mask 255.255.255.0
 dns-list 114.114.114.114 8.8.8.8
#
return
[S1-ip-pool-dhcp_vlan40]quit
[S1]display ip pool 
  -----------------------------------------------------------------------
  Pool-name      : dhcp_vlan30
  Pool-No        : 0
  Position       : Local           Status           : Unlocked
  Gateway-0      : 192.168.30.254  
  Mask           : 255.255.255.0
  VPN instance   : --
  -----------------------------------------------------------------------
  Pool-name      : dhcp_vlan40
  Pool-No        : 1
  Position       : Local           Status           : Unlocked
  Gateway-0      : 192.168.40.254  
  Mask           : 255.255.255.0
  VPN instance   : --
  IP address Statistic
    Total       :506   
    Used        :0          Idle        :506   
    Expired     :0          Conflict    :0          Disable   :0     
[S1]
(7) 配置vlanif 30和vlanif40虚接口下启用全局地址池
[S1]interface Vlanif 30 
[S1-Vlanif30]dhcp select global 
[S1-Vlanif30]display this
#
interface Vlanif30
 ip address 192.168.30.254 255.255.255.0
 dhcp select global
#
return
[S1-Vlanif30]quit
[S1]interface Vlanif 40
[S1-Vlanif40]dhcp select global
[S1-Vlanif40]display this
#
interface Vlanif40
 ip address 192.168.40.254 255.255.255.0
 dhcp select global
#
return
[S1-Vlanif40]quit
[S1]display ip pool name dhcp_vlan30 
  Pool-name      : dhcp_vlan30
  Pool-No        : 0
  Lease          : 1 Days 0 Hours 0 Minutes
  Domain-name    : -
  DNS-server0    : 114.114.114.114 
  DNS-server1    : 8.8.8.8        
  NBNS-server0   : -               
  Netbios-type   : -               
  Position       : Local           Status           : Unlocked
  Gateway-0      : 192.168.30.254  
  Mask           : 255.255.255.0
  VPN instance   : --
 -----------------------------------------------------------------------------
         Start           End     Total  Used  Idle(Expired)  Conflict  Disable
 -----------------------------------------------------------------------------
    192.168.30.1  192.168.30.254   253     1        252(0)         0        0
 -----------------------------------------------------------------------------
[S1]
[S1]display ip pool name dhcp_vlan40 
  Pool-name      : dhcp_vlan40
  Pool-No        : 1
  Lease          : 1 Days 0 Hours 0 Minutes
  Domain-name    : -
  DNS-server0    : 114.114.114.114 
  DNS-server1    : 8.8.8.8         
  NBNS-server0   : -               
  Netbios-type   : -               
  Position       : Local           Status           : Unlocked
  Gateway-0      : 192.168.40.254  
  Mask           : 255.255.255.0
  VPN instance   : --
 -----------------------------------------------------------------------------
         Start           End     Total  Used  Idle(Expired)  Conflict  Disable
 -----------------------------------------------------------------------------
    192.168.40.1  192.168.40.254   253     1        252(0)         0        0
 -----------------------------------------------------------------------------
[S1]
(8)保存S1交换机上的配置文件
[S1]q
<S1>save
The current configuration will be written to the device.
Are you sure to continue?[Y/N]y
Now saving the current configuration to the slot 0.
Save the configuration successfully.
<S1>


四、实验测试

执行ipconfig命令

执行ipconfig /release ——释放获取到的IP地址参数

执行ipconfig /renew——获取新的IP地址参数

f0f3646ec2a54d81a3f14e11c648f871.png

698d1bde614446e5adea0d87a64c842b.png

PC1

PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fe79:248a
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-79-24-8A
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fe79:248a
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.30.253
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.30.254
Physical address..................: 54-89-98-79-24-8A
DNS server........................: 114.114.114.114
                                    8.8.8.8
PC>


PC2

PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fe99:4726
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-99-47-26
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fe99:4726
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.40.253
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.40.254
Physical address..................: 54-89-98-99-47-26
DNS server........................: 114.114.114.114
                                    8.8.8.8
PC>


相关文章
|
11天前
|
消息中间件 安全 Unix
SSH配置多台服务器之间的免密登陆以及登陆别名
SSH配置多台服务器之间的免密登陆以及登陆别名
21 1
|
26天前
|
弹性计算
2024年阿里云服务器不同实例规格与配置实时优惠价格整理与分享
2024年阿里云服务器的优惠价格新鲜出炉,有特惠云服务器也有普通优惠价格,本文为大家整理汇总了2024年阿里云服务器的优惠价格,包含特惠云服务器和其他配置云服务器的优惠价格。以便大家了解自己想购买的云服务器选择不同实例规格和带宽情况下的价格,仅供参考。
2024年阿里云服务器不同实例规格与配置实时优惠价格整理与分享
|
8天前
|
存储 弹性计算 安全
阿里云服务器2核2G、2核4G配置最新租用收费标准及活动价格参考
2核2G、2核4G配置是很多个人和企业建站以及部署中小型的web应用等场景时首选的云服务器配置,这些配置的租用价格也是用户非常关心的问题,本文为大家整理汇总了2024年阿里云服务器2核2G、2核4G配置不同实例规格及地域之间的收费标准,同时整理了这些配置最新活动价格,以供大家参考和选择。
阿里云服务器2核2G、2核4G配置最新租用收费标准及活动价格参考
|
11天前
|
域名解析 网络协议 应用服务中间件
阿里云服务器配置免费https服务
阿里云服务器配置免费https服务
|
13天前
|
安全 关系型数据库 MySQL
国产麒麟服务器等保二级 配置规范(一)
国产麒麟服务器等保二级 配置规范(一)
32 0
|
14天前
|
数据采集
robots.txt配置 减小服务器压力
robots.txt配置 减小服务器压力
13 0
|
20天前
|
网络协议 安全 网络安全
二层交换机与防火墙对接上网配置示例
二层交换机指的是仅能够进行二层转发,不能进行三层转发的交换机。也就是说仅支持二层特性,不支持路由等三层特性的交换机。 二层交换机一般部署在接入层,不能作为用户的网关
|
24天前
|
网络协议 Linux 网络安全
Linux服务器DNS服务器配置实现bind的正向解释和反向解释
Linux服务器DNS服务器配置实现bind的正向解释和反向解释
17 0
|
26天前
|
弹性计算 网络安全 虚拟化
ECS数据问题之升级配置预防数据丢失如何解决
ECS(Elastic Compute Service,弹性计算服务)是云计算服务提供商提供的一种基础云服务,允许用户在云端获取和配置虚拟服务器。以下是ECS服务使用中的一些常见问题及其解答的合集:
|
27天前
|
弹性计算 Kubernetes 安全
ECS选型推荐配置
在构建Kubernetes集群时,应避免使用过多小规格ECS,因它们可能带来网络限制、容量不足和资源碎片化问题。采用大规格ECS能提升网络性能,优化镜像拉取效率。选择Master节点时,要考虑集群规模,生产环境建议选择较高规格。Worker节点推荐使用CPU≥4核、内存≥8GiB的ECS,根据集群总核数和容错率来决定节点数量。当规模达1000核,可选用裸金属神龙服务器,它提供超强网络、零计算抖动和安全性能,适合大促等需快速扩展的场景。
26 1