npm install less-loader报错 npm查看版本号

简介: npm install less-loader报错 npm查看版本号

**Vue来发项目的时候 使用less默认npm install less-loader 报错
因为webpack的版本号和less-loader的不匹配导致的**

查看版本号:

npm view xxx versions

查看webpack开始到最新的所有版本号:最高到5.x版本

npm  view webpack versions

在这里插入图片描述

查看less-loader的所有版本号

npm  view  less-loader versions

最高到10.x版本
在这里插入图片描述

解决问题:

**打开vue项目的node_modules打开webpack的package.json查看他的版本
4.x的最高版本**

在这里插入图片描述
所以我们安装less-loader的时候选择相差不大的版本即可 建议选择范围为5 6 7 建议7

安装less-loader@7 按照的7的最新版本7.3.0

npm install less-loader@7
相关文章
|
2月前
|
开发工具
npm install 卡死问题解决
npm install 卡死问题解决
|
2月前
|
前端开发 开发工具 git
GitLab npm install ERROR
GitLab npm install ERROR
|
1月前
|
JavaScript
node.js 项目中执行 npm install 命令后看到的 idealTree inflate 的含义
node.js 项目中执行 npm install 命令后看到的 idealTree inflate 的含义
43 0
|
3月前
npm run dev启动报错:Error: Cannot find module 'semver'
npm run dev启动报错:Error: Cannot find module 'semver'
70 0
|
22天前
|
JavaScript
报错:npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
报错:npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
|
22天前
|
前端开发 JavaScript
npm install --save 和 npm install --save-dev区别
npm install --save 和 npm install --save-dev区别
|
22天前
|
安全 JavaScript 开发者
关于 npm install 执行时的安全审计工作
关于 npm install 执行时的安全审计工作
14 0
|
22天前
|
JavaScript 数据可视化
关于 npm install 命令行自行时看到的 timing 输出
关于 npm install 命令行自行时看到的 timing 输出
11 0
|
22天前
|
开发者
使用 --loglevel verbose 参数查看 npm install 安装过程中的更多细节
使用 --loglevel verbose 参数查看 npm install 安装过程中的更多细节
16 0
|
29天前
|
JavaScript
无法安装Vue脚手架 npm install @vue/cli -g
无法安装Vue脚手架 npm install @vue/cli -g