HDOJ 2052 Picture

简介: HDOJ 2052 Picture

Problem Description

Give you the width and height of the rectangle,darw it.


Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.


Output

For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line.


Sample Input

3 2

Sample Output
+---+
|   |
|   |
+---+


别忘了每一个输出后面空一行

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int m = sc.nextInt();
            int n = sc.nextInt();
            for(int i=0;i<n+2;i++){
                for(int j=0;j<m+2;j++){
                    if(i==0){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else if(i==n+1){
                        if(j==0||j==m+1){
                            System.out.print("+");
                        }else{
                            System.out.print("-");
                        }
                    }else {
                        if(j==0||j==m+1){
                            System.out.print("|");
                        }else{
                            System.out.print(" ");
                        }
                    }
                }
                System.out.println();
            }
            System.out.println();
        }
    }
}
目录
相关文章
|
Java 数据安全/隐私保护
HDOJ 2100 Lovekey
HDOJ 2100 Lovekey
100 0
HDOJ 2004 成绩转换
HDOJ 2004 成绩转换
92 0
HDOJ 2013 蟠桃记
HDOJ 2013 蟠桃记
95 0
HDOJ 2019 数列有序!
HDOJ 2019 数列有序!
124 0
|
机器学习/深度学习
HDOJ 2074 叠筐
Problem Description 需要的时候,就把一个个大小差一圈的筐叠上去,使得从上往下看时,边筐花色交错。这个工作现在要让计算机来完成,得看你的了。 Input 输入是一个个的三元组,分别是,外筐尺寸n(n为满足0< n< 80的奇整数),中心花色字符,外筐花色字符,后二者都为ASCII可见字符; Output 输出叠在一起的筐图案,中心花色与外筐花色字符从内层起交错相叠,多筐相叠时,最外筐的角总是被打磨掉。
842 0