A - Wireless Network

简介: POJ-2236 Time Limit: 10000MS Memory Limit: 65536KDescription An earthquake takes place in Southeast Asia.

POJ-2236

Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

并查集

//AC:3219MS  712kB
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
struct{
    int x,y;
    int rank;
    int parent;
}node[1005];
int compare(int a,int b,int d){
    if((node[a].x-node[b].x)*(node[a].x-node[b].x)+(node[a].y-node[b].y)*(node[a].y-node[b].y)<=d*d)
        return 1;
    else
        return 0;
}
int find(int a){
    if(node[a].parent==a)
        return a;
    return find(node[a].parent);
}
void Union(int a,int b){
    a=find(a);
    b=find(b);
    if(node[a].rank>node[b].rank)
        node[b].parent=a;
    else{
        node[a].parent=b;
        if(node[a].rank==node[b].rank)
            node[b].rank++;
    }
}
int main(){
    int N,d;
    scanf("%d%d",&N,&d);
    for(int i=1;i<=N;i++)
        scanf("%d%d",&node[i].x,&node[i].y);
    char D;
    while(scanf("%c",&D)!=EOF){
        if(D=='O'){
            int a;
            scanf("%d",&a);
            node[a].rank=0;
            node[a].parent=a;
            for(int i=1;i<=N;i++){
                if(node[i].parent){
                    if(compare(a, i, d)){
                        Union(a,i);
                    }
                }
            }
        }
        if(D=='S'){
            int a,b;
            scanf("%d%d",&a,&b);
            a=find(a);
            b=find(b);
            if(a==b)
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}
目录
相关文章
|
1月前
POJ—2236 Wireless Network
POJ—2236 Wireless Network
|
Ubuntu Linux
Wireless-N 7265
ubuntu linux wifi
|
网络协议 网络虚拟化

热门文章

最新文章