开发者社区 > 云原生 > 微服务 > 正文

Nacos不兼容mysql8吗?

Nacos不兼容mysql8吗?完全相同的部署过程,用mysql5就是正常的,用mysql8就,nacos容器会反复重启。

展开
收起
真的很搞笑 2024-06-16 19:50:09 32 0
3 条回答
写回答
取消 提交回答
  • 支持 ,此回答整理自钉群“Nacos社区群4”

    2024-06-17 20:24:01
    赞同 展开评论 打赏
  • 北京阿里云ACE会长

    Nacos 与 MySQL 8 的兼容性问题在过去的一些版本中确实存在

    检查数据库连接配置,确保 JDBC URL、用户名、密码等信息正确无误。
    确保使用的是与 MySQL 8 兼容的 JDBC 驱动版本。

    2024-06-17 08:08:29
    赞同 展开评论 打赏
  • 支持的。nacos 1.3.1以上版本已经正式升级到mysql8.0版本,无需自行切换版本号。
    image.png

    ——参考链接

    2024-06-17 08:08:20
    赞同 1 展开评论 打赏

为微服务建设降本增效,为微服务落地保驾护航。

相关电子书

更多
搭建电商项目架构连接MySQL 立即下载
搭建4层电商项目架构,实战连接MySQL 立即下载
PolarDB MySQL引擎重磅功能及产品能力盛大发布 立即下载

相关镜像