开发者社区 > 云原生 > 正文

大佬们,请问java 服务端的dubbo版本为2.7,dubbo-go需要用哪个版本?

大佬们,请问java 服务端的dubbo版本为2.7,dubbo-go需要用哪个版本?

展开
收起
cuicuicuic 2023-06-28 17:34:34 72 0
2 条回答
写回答
取消 提交回答
  • 如果您的Java服务端使用的是Dubbo版本2.7,那么您可以使用Dubbo-Go的v1.7.0及更高版本。Dubbo-Go是一个使用Go语言实现的Dubbo框架的兼容版本,它与Java版本的Dubbo具有相同的协议和数据格式,可以实现跨语言的服务调用和互操作。

    根据Dubbo-Go的官方文档,Dubbo-Go v1.7.0 版本开始与Dubbo Java 2.7.x系列兼容。这意味着您可以使用Dubbo-Go v1.7.0或更新版本与您的Java服务端进行交互,实现跨语言的服务调用。

    建议您根据具体需求和使用场景选择最新的Dubbo-Go版本,以获得最新的功能和改进。您可以在Dubbo-Go的官方仓库(https://github.com/apache/dubbo-go)中查找并下载适当版本的Dubbo-Go,并参考其文档和示例进行配置和使用。

    请注意,由于Dubbo-Go是Dubbo的兼容版本,具体的兼容性和功能支持可能会受到Dubbo-Go版本的影响。建议在选择和使用Dubbo-Go时仔细阅读其文档和指南,并确保您的Java服务端和Dubbo-Go版本之间的兼容性。

    2023-06-29 17:44:40
    赞同 展开评论 打赏
  • 北京阿里云ACE会长

    如果您使用的是 Dubbo 2.7.x 版本作为 Java 服务端,建议您使用 Dubbo-go 1.5.x 或以上版本。

    Dubbo-go 1.5.x 版本是针对 Dubbo 2.7.x 版本进行兼容性优化的版本,包括与 Dubbo 2.7.x 版本的协议兼容性、注册中心兼容性等方面的优化。因此,如果您使用 Dubbo-go 1.5.x 版本,可以更好地与 Dubbo 2.7.x 版本配合使用。

    需要注意的是,在使用 Dubbo-go 1.5.x 或以上版本时,需要调整 Dubbo-go 的配置,以确保与 Dubbo 2.7.x 版本的兼容性。例如,您需要使用 Dubbo-go 1.5.x 版本的注册中心插件,以确保 Dubbo-go 能够正常注册和订阅服务。同时,您还需要将 Dubbo-go 的协议版本设置为 Dubbo 2.7.x 版本的协议版本,以确保 Dubbo-go 能够正确解析和处理 Dubbo 2.7.x 版本的协议。

    2023-06-28 18:57:56
    赞同 展开评论 打赏

阿里云拥有国内全面的云原生产品技术以及大规模的云原生应用实践,通过全面容器化、核心技术互联网化、应用 Serverless 化三大范式,助力制造业企业高效上云,实现系统稳定、应用敏捷智能。拥抱云原生,让创新无处不在。

相关电子书

更多
Spring Cloud Alibaba - 重新定义 Java Cloud-Native 立即下载
The Reactive Cloud Native Arch 立即下载
JAVA开发手册1.5.0 立即下载