开发者社区 > 云原生 > 正文

请问Dubbo-go中java 服务端的dubbo版本为2.7,dubbo-go需要用哪个版本

请问java 服务端的dubbo版本为2.7,dubbo-go需要用哪个版本

展开
收起
2401。 2023-06-28 09:34:07 61 0
1 条回答
写回答
取消 提交回答
  • 如果Java服务端的Dubbo版本为2.7,您可以在Dubbo-go中使用Dubbo-go的v1.7.0版本。这个版本是Dubbo-go对应Dubbo 2.7.x版本的兼容版本,可以与Java服务端进行通信和交互。

    请注意,Dubbo-go的版本与Java服务端的Dubbo版本不一定完全匹配,但v1.7.0版本是与Dubbo 2.7.x版本兼容的版本。如果您使用其他版本的Dubbo-go,可能会导致与Java服务端的通信出现问题。

    您可以通过以下方式在Go项目中使用Dubbo-go的v1.7.0版本:

    go get github.com/apache/dubbo-go@v1.7.0
    

    然后在您的Go代码中引入Dubbo-go的包:

    import (
        "github.com/apache/dubbo-go/config"
        // 其他依赖包
    )
    

    接下来,您可以根据Dubbo-go的文档和示例代码,配置和使用Dubbo-go与Java服务端进行通信。

    2023-06-28 10:02:58
    赞同 展开评论 打赏

阿里云拥有国内全面的云原生产品技术以及大规模的云原生应用实践,通过全面容器化、核心技术互联网化、应用 Serverless 化三大范式,助力制造业企业高效上云,实现系统稳定、应用敏捷智能。拥抱云原生,让创新无处不在。

相关电子书

更多
Go语言路上踩过的坑 立即下载
gohbase :HBase go客户端 立即下载
Go构建日请求千亿级微服务实践 立即下载