HDU-1045,Fire Net(经典DFS)

简介: HDU-1045,Fire Net(经典DFS)

Problem Description:


Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.


A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.


Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.


The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.


The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.


网络异常,图片无法展示
|


Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.



Input:


The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.  


Output:


For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.


Sample Input:


4


.X..


....


XX..


....


2


XX


.X


3


.X.


X.X


.X.


3


...


.XX


.XX


4


....


....


....


....


0


Sample Output:


5

1

5

2

4


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char map[10][10];
int n,ans;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int find(int x,int y)
{
  for(int i=0;i<4;i++)
  {
    for(int k=0;k<=3;k++)
    {
      int tx,ty;
      tx=x+dir[i][0]*k;
      ty=y+dir[i][1]*k;
      if(tx<0||tx>n-1||ty<0||ty>n-1)
        break;
      if(map[tx][ty]=='X')
        break;
      if(map[tx][ty]=='D')
        return 0;
    }
  }
  return 1;
}
void dfs(int step)
{
  ans=max(ans,step);
  for(int i=0;i<n;i++)
  {
    for(int j=0;j<n;j++)
    {
      if(map[i][j]=='.'&&find(i,j))
      {
        map[i][j]='D';
        dfs(step+1);
        map[i][j]='.';
      }
    }
  }
}
int main()
{
  while(scanf("%d",&n)&&n)
  {
    for(int i=0;i<n;i++)
      scanf("%s",map[i]);
    ans=0;
    dfs(0);
    printf("%d\n",ans);
  }
  return 0;
}



相关文章
|
算法
ZOJ(ZJU) 1002 Fire Net(深搜)
ZOJ(ZJU) 1002 Fire Net(深搜)
100 0
ZOJ(ZJU) 1002 Fire Net(深搜)
|
定位技术 机器学习/深度学习
|
机器学习/深度学习
|
算法 机器学习/深度学习 定位技术
ZOJ 1002 - Fire Net 的答案(回溯法)
---------------------------------------------------------------------------------------------------------------------------        严格来讲,此题并不算我做出来的。
1012 0
|
2月前
|
开发框架 前端开发 JavaScript
ASP.NET MVC 教程
ASP.NET 是一个使用 HTML、CSS、JavaScript 和服务器脚本创建网页和网站的开发框架。
41 7
|
2月前
|
存储 开发框架 前端开发
ASP.NET MVC 迅速集成 SignalR
ASP.NET MVC 迅速集成 SignalR
58 0
|
3月前
|
开发框架 前端开发 .NET
ASP.NET MVC WebApi 接口返回 JOSN 日期格式化 date format
ASP.NET MVC WebApi 接口返回 JOSN 日期格式化 date format
47 0
|
3月前
|
开发框架 前端开发 安全
ASP.NET MVC 如何使用 Form Authentication?
ASP.NET MVC 如何使用 Form Authentication?