ECS降级glibc解决依赖问题-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

ECS降级glibc解决依赖问题

简介: Centos7降级glibc解决依赖问题

最近在阿里云ECS上安装软件,出现了glibc版本的问题,初步一看是由于glibc版本太高了,导致安装失败

部分glibc报错内容如下:

Error: Package: glibc-2.17-260.el7_6.6.i686 (updates)

       Requires: glibc-common = 2.17-260.el7_6.6
       Installed: glibc-common-2.17-323.el7_9.x86_64 (@updates)
           glibc-common = 2.17-323.el7_9
       Available: glibc-common-2.17-260.el7.x86_64 (base)
           glibc-common = 2.17-260.el7
       Available: glibc-common-2.17-260.el7_6.3.x86_64 (updates)
           glibc-common = 2.17-260.el7_6.3
       Available: glibc-common-2.17-260.el7_6.4.x86_64 (updates)
           glibc-common = 2.17-260.el7_6.4
       Available: glibc-common-2.17-260.el7_6.5.x86_64 (updates)
           glibc-common = 2.17-260.el7_6.5
       Available: glibc-common-2.17-260.el7_6.6.x86_64 (updates)
           glibc-common = 2.17-260.el7_6.6

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

解决办法:

通过yum downgrade降级版本

yum downgrade glibc glibc-devel glibc-common glibc-headers

注意:glibc这几个包都是互相关联的,所以仅仅降级glibc-common是不行的

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享: