[ACMcoder] Let the Balloon Rise

简介: Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When th

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

解题思路

实现代码

#include <iostream>
#include <string>
#include <unordered_map>
using namespace std;

int main()
{
    int n;
    string color;
    while (cin>>n)
    {
        if (n == 0) break;
        unordered_map<string, int> colormap;
        while (n--)
        {
            cin>>color;
            colormap[color]++;
        }

        int max = 0;
        int count;
        string popColor;
        for (auto it = colormap.begin(); it != colormap.end(); it++)
        {
            count = it->second;
            if (count > max)
            {
                max = count;
                popColor = it->first;
            }
        }
        cout<<popColor.c_str()<<endl;
    }
}
目录
相关文章
|
6月前
|
Java
HDU-1004—Let the Balloon Rise
HDU-1004—Let the Balloon Rise
30 0
[USACO 2021.02 Feb]Problem 3. Clockwise Fence
[USACO 2021.02 Feb]Problem 3. Clockwise Fence
HDOJ 1004 Let the Balloon Rise
HDOJ 1004 Let the Balloon Rise
139 0
HDOJ 1004题 Let the Balloon Rise strcmp()函数
HDOJ 1004题 Let the Balloon Rise strcmp()函数
105 0
|
.NET 开发框架 JavaScript