开发者社区> 科技小先锋> 正文

Vlan配置详解之三层交换

简介:
+关注继续查看
文章包括下面内容:
配置VLAN;配置VTP;用三层交换提供VLAN间路由;在三层交换上配置DHCP为各VLAN分配IP
实验所用硬件:
Cisco3600+NM-16ESW交换模块
拓扑图如下:
图中两台交换机都是采用Cisco3600+NM-16ESW
 
逻辑规划:
VLAN 2 IP段是192.168.1.0/24 成员PC1PC4IP分别为192.168.1.11192.168.1.44;成员网关是192.168.1.1
VLAN 3IP段是192.168.2.0/24 成员PC2PC3IP分别为192.168.2.22192.168.2.33;成员网关是192.168.2.1
VLAN 1IP段是192.168.0.0/24 成员SW1SW2IP分别为:192.168.0.2 192.168.0.3;成员网关是192.168.0.1
 
一、            配置PC
照上述IP地址方案将PCIP配置好。
二、            配置交换机
配置SW1VTP Server
Router>en
Router#conf t
Router(config)#no cdp run //关闭CDP协议
Router(config)#no ip domain lookup //关闭名称解析
Router(config)# ip routing //打开路由功能因为SW1要提供VLAN间路由。
Router(config)#line console 0
Router(config-line)#logging synchronous //控制台信息同步,避免干扰
Router(config-line)#exec-timeout 0 0  //永不超时,但离开控制台时要即时关闭
Router(config-line)#exit
Router(config)#hostname SW1
SW1(config)#interface range fa0/0 - 15
SW1(config-if-range)#shutdown  //同时关闭16个端口
SW1(config)#interface range fa0/1 - 2
SW1(config-if-range)#no shut
SW1(config-if-range)#switchport mode access //fa0/1fa0/2口激活并设为访问口,因为连接的是PC
SW1(config)#int  fa0/15
SW1(config-if)#no shut  
SW1(config-if)#switchport mode trunk  //连接的是SW2,要设成中继链路,链路默认采用802.1Q封装
配置SW2VTP Client
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no cdp run //关闭CDP协议
Router(config)#no ip domain lookup //关闭名称解析
Router(config)#no ip routing //关闭路由功能否则交换机将不能和PC通信。
Router(config)#line console 0
Router(config-line)#logging synchronous //控制台信息同步,避免干扰
Router(config-line)#exec-timeout 0 0  //永不超时,但离开控制台时要即时关闭
Router(config-line)#exit
Router(config)#hostname SW2
SW2(config)#int range fa0/0 - 15
SW2(config-if-range)#shutdown
SW2(config-if-range)#exit
SW2(config)#int r
SW2(config)#int range fa0/0 - 1
SW2(config-if-range)#no shutdown
SW2(config-if-range)#switchport mode access //连接的是PC3PC4
SW2(config)#int fa0/15
SW2(config-if)#no shut
SW2(config-if)#switchport mode trunk //连接的是SW1
SW2#vlan database
SW2(vlan)#vtp client
SW2(vlan)#vtp domain Cisco
SW2(vlan)#vtp password abc
SW2(vlan)#vtp pruning
SW2(vlan)#exit 
 
SW2(config)#int vlan 1
SW2(config-if)#ip address 192.168.0.3 255.255.255.0
SW2(config-if)#no shut
SW2(config-if)#exit
SW2(config)#ip default-gateway 192.168.0.1 //不可少
SW2(config)#int fa0/0
SW2(config-if)#switchport access vlan 3
SW2(config-if)#int fa0/1
SW2(config-if)#switchport access vlan 2  //配置到这里的时候相同VLAN的成员之间可以互相通信,但不同VLAN成员之间不能通信。
 
要实现VLAN间路由要在SW1上接着做如下配置:
Router(config)#int vlan 2  //在三层交换上把每一个VLAN都看成是一个接口。
SW1(config-if)#ip address 192.168.1.1 255.255.255.0
SW1(config-if)#no shut
SW1(config-if)#int vlan 3
SW1(config-if)#ip address 192.168.2.1 255.255.255.0
SW1(config-if)#no shut
到此三层交换做VLAN间路由就做完了!如果要做VLAN间通信的特殊限制可以做ACL,记住:在三层交换上把每一个VLAN都看成是一个接口,不然在应用ACL的时候你就有麻烦了!
 
上面的VLAN成员IP都是手动指定的,我们可以在SW1上为每个VLAN配置一个地址池,为每个VLAN自动分配IP和DNS等相关信息,也可以用网络中现有DHCP服务器为各成员分配IP,不管哪种方式都要定义相关VLAN的地址范围。个人觉得还是就近在设备上做地址池方便。配置如下:
SW1(config)#ip dhcp pool v2
SW1(dhcp-config)#network 192.168.1.0 255.255.255.0
SW1(dhcp-config)#default-router 192.168.1.1
SW1(dhcp-config)#lease 5
SW1(dhcp-config)#exit
SW1(config)#ip dhcp pool v3
SW1(dhcp-config)#network 192.168.2.0 255.255.255.0
SW1(dhcp-config)#default-router 192.168.2.1
SW1(dhcp-config)#lease 5
SW1(dhcp-config)#exit
SW1(config)#int vlan 2
SW1(config-if)#ip helper-address 192.168.0.1 //这个地址也可以换成192.168.1.1或192.168.2.1。
SW1(config-if)#int vlan 3
SW1(config-if)#ip helper-address 192.168.0.1
SW1(config-if)#exit
不分配下列地址
SW1(config)#ip dhcp excluded-address 192.168.0.1 //VLAN1 地址
SW1(config)#ip dhcp excluded-address 192.168.1.1 //VLAN2 网关
SW1(config)#ip dhcp excluded-address 192.168.2.1 //VLAN3 网关
SW1(config)#ip dhcp excluded-address 192.168.0.2 //SW2VLAN1地址
 
各VLAN成员只要将自己的IP设置成自动获取就可以得到正确的IP了!
 

本文转自Y.weisheng 51CTO博客,原文链接:http://blog.51cto.com/yuan2/95792,如需转载请自行联系原作者

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
阿里云服务器端口号设置
阿里云服务器初级使用者可能面临的问题之一. 使用tomcat或者其他服务器软件设置端口号后,比如 一些不是默认的, mysql的 3306, mssql的1433,有时候打不开网页, 原因是没有在ecs安全组去设置这个端口号. 解决: 点击ecs下网络和安全下的安全组 在弹出的安全组中,如果没有就新建安全组,然后点击配置规则 最后如上图点击添加...或快速创建.   have fun!  将编程看作是一门艺术,而不单单是个技术。
18630 0
阿里云服务器如何登录?阿里云服务器的三种登录方法
购买阿里云ECS云服务器后如何登录?场景不同,阿里云优惠总结大概有三种登录方式: 登录到ECS云服务器控制台 在ECS云服务器控制台用户可以更改密码、更换系.
25049 0
postgresql安装配置
一,什么是postgresql PostgreSQL是以加州大学伯克利分校计算机系开发的 POSTGRES 版本 4.2 为基础的对象关系型数据库管理系统(ORDBMS),简称pgsql,它支持大部分 SQL 标准并且提供了许多其他现代特性:复杂查询 外键 触发器 视图 事务完整性 多版本并发控制 同样,PostgreSQL 可以用许多方法扩展,比如, 通过增加新的:数据类型 函数 操作符 聚集函数 索引方法 过程语言 并且,因为许可证的灵活,任何人都可以以任何目的免费使用,修改,和分发 PostgreSQL, 不管是私用,商用,还是学术研究使用。
788 0
阿里云服务器怎么设置密码?怎么停机?怎么重启服务器?
如果在创建实例时没有设置密码,或者密码丢失,您可以在控制台上重新设置实例的登录密码。本文仅描述如何在 ECS 管理控制台上修改实例登录密码。
20352 0
postgresql安装配置
一,什么是postgresql PostgreSQL是以加州大学伯克利分校计算机系开发的 POSTGRES 版本 4.2 为基础的对象关系型数据库管理系统(ORDBMS),简称pgsql,它支持大部分 SQL 标准并且提供了许多其他现代特性:复杂查询 外键 触发器 视图 事务完整性 多版本并发控制 同样,PostgreSQL 可以用许多方法扩展,比如, 通过增加新的:数据类型 函数 操作符 聚集函数 索引方法 过程语言 并且,因为许可证的灵活,任何人都可以以任何目的免费使用,修改,和分发 PostgreSQL, 不管是私用,商用,还是学术研究使用。
860 0
Notepad++配置Golang开发环境
简述 Notepad++ 不支持 Go 语言的立即使用,可以为其安装 GOnpp 插件。安装之前,需要先配置好 Go 的环境。 简述 安装 Go 开发插件 配置语法高亮 更多参考 安装 Go 开发插件 运行 Notepad++ 软件 打开菜单,选择:插件 -> Plugin Manager -> Show Plugin Manage
1396 0
在 ML2 中配置 Vlan Network- 每天5分钟玩转 OpenStack(93)
上一节我们学习了 Neutron Vlan Network 的原理,今天讨论如何在 ML2 配置中 enable 它。 首先在 /etc/neutron/plugins/ml2/ml2_conf.ini 中设置 vlan network 相关参数。
980 0
Spring配置c3p0数据源时出错报:java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector
今天在使用Spring配置c3p0数据源时,使用的数据库是mysql,服务器是tomcat,运行时报了一个 java.lang.NoClassDefFoundError: com/mchange/v2/ser/Indirector 网络上找了很久都没有解决,最后发现是因为:         C3P0 少了个 jar 包,mchange-commons-java-0.
1131 0
6967
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
JS零基础入门教程(上册)
立即下载
性能优化方法论
立即下载
手把手学习日志服务SLS,云启实验室实战指南
立即下载