cisco交换机-初级命令与例子

简介:

 点击大图

环境
模拟器 cisco packet tracer version:5.3.2.0027
虚拟交换机 cisco 3560/2950/2960 
vlan:vlan 10 to vlan 90(vlan 91 - vlan 93);vlan 200 
ip:192.168.0/16

目的:设计某公司网络拓扑图,学习基础的cisco 交换机命令、vlan、trunking、三层交换机路由。

参考
http://book.51cto.com/art/200709/55653.htm
http://cisco.chinaitlab.com/base/391943.html
cisco 3560 手册


#######################################################################
#路由相关 (重要,三层交换机上)
sw0(config)#ip routing                                   #开启路由,各个vlan之间可以互通
sw0(config)#no ip routing                                #关闭路由,各个vlan之间则不通了
sw1(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2         #添加静态路由
sw1(config)#no ip route 0.0.0.0 0.0.0.0                  #删除路由
比如
vlan 90 交换机为sw9(汇聚层), 再次划分了3个vlan (连接下面的三台交换机,这样又划分了3个广播域 ) 
vlan 91, vlan 92, vlan 93,当关闭路由时那么这个vlan的ip不能与其它vlan的ip 通信,相反则可以通信!
小结 各个vlan间互通,不但需要设定vlan接口ip地址,而且还需要开启ip routing !!!

sw0#show ip route                                        #显示路由表
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.0.0/24 is directly connected, Vlan200
C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20
C    192.168.30.0/24 is directly connected, Vlan30
C    192.168.40.0/24 is directly connected, Vlan40
C    192.168.50.0/24 is directly connected, Vlan50
C    192.168.60.0/24 is directly connected, Vlan60
C    192.168.70.0/24 is directly connected, Vlan70
C    192.168.80.0/24 is directly connected, Vlan80
C    192.168.90.0/24 is directly connected, Vlan90

#######################################################################
#vlan相关
vlan的主要作用有两点,一是提高网络安全性,阻止未经授权的vlan访问,
二是提高网络传输效率,缩小广播域。
sw0>                                                    #非特权模式
sw0>enable                                              #进入特权模式
sw0#configure terminal                                  #进入全局模式

sw0(config)#vlan 200                                    #创建并进入vlan视图
sw0(config-vlan)#exit                                   #退出vlan视图

sw0(config)#interface fastEthernet 0/24                 #进入端口视图
sw0(config-if)#switchport access vlan 200               #设置此端口为vlan 200 (二层口)
sw0(config-if)#exit                                     #退出端口视图

sw0(config)#interface vlan 200                          #创建并进入vlan接口视图
%LINK-5-CHANGED: Interface Vlan200, changed state to up
sw0(config-if)#ip address 192.168.0.2 255.255.255.0     #设置ip地址
sw0(config-if)#no shutdown                              #激活端口

sw0#show vlan id 200                                    #查看vlan配置(不指定id 即 show vlan 则显示全部vlan配置 )
sw0#show interfaces fastEthernet 0/24                   #查看端口配置
sw0#show interfaces vlan 200                            #查看vlan接口

sw0(config)#no vlan 200                                 #删除vlan     
sw0(config)#no interface vlan 200                       #删除vlan接口


#dhcp relay 相关
sw0(config)#ip dhcp excluded-address 192.168.0.1       #设置 dhcp 服务器ip地址 (Configure DHCP server or relay parameters)
sw0(config)#int vlan 10                                #进入vlan 接口视图
sw0(config-if)#ip helper-address 192.168.0.1           #指定广播的目的地址ip (Specify a destination address for UDP broadcasts)

#第一个例子
步骤
1 创建vlan 10 - vlan 90
2 为 vlan 10 - vlan 90 分配端口
3 创建vlan 10 - vlan 90 接口,并分配ip地址
4 打开dhcp中继,并指定vlan 10 - vlan 90 dhcp ip 地址

#create vlan
sw0(config)#vlan 10
sw0(config-vlan)#exit
......中间的vlan 20 vlan - vlan 80 方法相同所以略过
sw0(config)#vlan 90
sw0(config-vlan)#exit


#port for vlans
sw0(config)#interface fa 0/1
sw0(config-if)#switchport access vlan 10
sw0(config-if)#exit
......中间的vlan 20 vlan - vlan 80 方法相同所以略过
sw0(config)#int fa 0/9                          #注意命令开始缩写了!O(∩_∩)O~
sw0(config-if)#switchport access vlan 90
sw0(config-if)#exit


#create vlan interface
sw0(config)#int vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
sw0(config-if)#ip add 192.168.10.1 255.255.255.0
sw0(config-if)#no shutdown
sw0(config-if)#exit
......中间的vlan 20 vlan - vlan 80 方法相同所以略过
sw0(config)#int vlan 90
%LINK-5-CHANGED: Interface Vlan90, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan90, changed state to up
sw0(config-if)#ip add 192.168.90.1 255.255.255.0
sw0(config-if)#no shutdown
sw0(config-if)#exit


#dhcp relay
sw0(config)#ip dhcp excluded-address 192.168.0.1  #设置 dhcp 服务器ip地址 (Configure DHCP server or relay parameters)
                                                  #上一条命令只需要执行一次即可.
sw0(config)#int vlan 10                           #进入vlan 接口视图
sw0(config-if)#ip helper-address 192.168.0.1      #指定广播的目的地址ip (Specify a destination address for UDP broadcasts)
sw0(config-if)#exit
......中间的vlan 20 vlan - vlan 80 方法相同所以略过
sw0(config)#int vlan 90
sw0(config-if)#ip helper-address 192.168.0.1
sw0(config-if)#exit

小结
三层交换机配置顺序
1创建vlan 
2蒋某端口分配给vlan 
3创建vlan接口,并分配ip地址

#######################################################################
#trunk 相关(重要)
我们知道当没有三层交换机或单臂路由器时,各个vlan之间是不能互通的!
到底什么是trunk?trunk与vlan有什么关系那?
当在交换机上划分有多个vlan时,只使用一条链路实现与其他交换机的通信,这就是trunk !!!!!

不同的交换机的相同vlan id的vlan 是可以互通的;比如在两个交换机上分别划分了两个vlan,当两个交换机上的vlan10和vlan90如果要互通,就需要在

switchA上设为vlan10的端口中,取一个和交换机B上设为vlan10的某个端口作级联连接。vlan90也是这样。那么如果交换机上划了10个vlan就需要分别连10条线

作级联,端口效率就太低了。 
当交换机支持trunking的时候,事情就简单了,只需要两个交换机之间有一条级联线,并将对应的端口设置为trunk,这条线路就可以承载交换机上所有vlan的

信息,这样的话就算交换机上设了上百个vlan也只用1个端口就解决了。

注意
trunk应当在相互连接的两台交换机上分别设置,否则,trunk将无法生效。也就是说,当在汇聚交换机的级联端口上设置了trunk端口后,还应当在核心交换机

的相应端口上设置trunk;同时在核心交换机上必须创建汇聚交换机的全部VLAN ID !!!


sw9>en
sw9#conf ter
sw9(config)#int fa 0/10                              #进入端口视图(这里使用了缩写,完整命令为 interface fastEthernet 0/10)
sw9(config-if)#switchport mode ?                     #? 提供相关帮助,可以看到有三种模式
  access   Set trunking mode to ACCESS unconditionally                     #模式为接入模式
  dynamic  Set trunking mode to dynamically negotiate access or trunk mode #动态的
  trunk    Set trunking mode to TRUNK unconditionally
sw9(config-if)#switchport mode trunk                 #指定端口为trunk模式
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up
sw9(config-if)#no shutdown


#第二个例子
步骤
1 为sw9(汇聚层)交换机,划分3个vlan (vlan91 vlan92 vlan93)并分配端口,用于分割广播域。
2 为了传递这些vlan信息,需要将sw9(汇聚层)交换机 与 sw0(核心层)交换机的级联端口设置为trunk模式。
3 在sw0交换机上建立上面的3个vlan(不用指定端口),建立相应的vlan接口并指定接口ip地址。


#sw9 create vlan                                       #sw9交换机
sw9>en
sw9#conf ter
sw9(config)#vlan 91                                    #创建并进入vlan视图
sw9(config-vlan)#exit                                  #退出vlan视图
sw9(config)#vlan 92
sw9(config-vlan)#exit
sw9(config)#vlan 93
sw9(config-vlan)#exit

sw9(config)#int range fa 0/2 - fa 0/9                  #range命令用于配置一组端口(\(^o^)/~)
sw9(config-if-range)#switchport access vlan 91         #设置此组端口为vlan 91
sw9(config-if-range)#exit
sw9(config)#int range fa 0/10 - fa 0/17
sw9(config-if-range)#switchport access vlan 92         #设置此组端口为vlan 92
sw9(config-if-range)#exit
sw9(config)#int range fa 0/18 - fa 0/24
sw9(config-if-range)#switchport access vlan 93         #设置此组端口为vlan 93
sw9(config-if-range)#exit

#sw9 and sw0 configure trunk
sw9(config)#int fa 0/1                                #sw9交换机
sw9(config-if)#switchport mode trunk                   #指定端口为trunk模式(sw9)
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
sw9(config-if)#no shutdown

sw0(config)#int fa 0/9                                 #sw0交换机
sw0(config-if)#switchport mode trunk                   #指定端口为trunk模式(sw0)
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan90, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/9, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan90, changed state to up
sw0(config-if)#no shutdown

#sw0 create vlan ,vlan interface ,configure ip 
sw0(config)#vlan 91                                    #创建并进入vlan视图
sw0(config-vlan)#exit                                  #退出vlan视图
sw0(config)#vlan 92
sw0(config-vlan)#exit
sw0(config)#vlan 93
sw0(config-vlan)#exit
                                                       #注意sw0交换机没有给vlan分配端口!!!
sw0(config)#int vlan 91                                #创建并进入vlan接口视图
%LINK-5-CHANGED: Interface Vlan91, changed state to up
sw0(config-if)#ip add 192.168.91.1 255.255.255.0       #指定接口ip地址
sw0(config-if)#no shutdown 
sw0(config-if)#exit

sw0(config)#int vlan 92
%LINK-5-CHANGED: Interface Vlan92, changed state to up
sw0(config-if)#ip add 192.168.92.1 255.255.255.0
sw0(config-if)#no shut
sw0(config-if)#exit

sw0(config)#int vlan 93
%LINK-5-CHANGED: Interface Vlan93, changed state to up
sw0(config-if)#ip add 192.168.93.1 255.255.255.0
sw0(config-if)#no shut
sw0(config-if)#exit

小结
1 交换机的级联口都需要设置为trunk!
2 允许所有vlan通过,这是默认的不需设置!(sw0(config-if)#switchport trunk allowed vlan all)
3 三层交换机上,使用trunk 就不需要给上边的vlan指定端口啦,因为trunk承载了所有vlan信息(就是不同的vlan 合用一个端口)!
4 三层交换机上,配置 vlan虚接口ip地址后,路由表将添加相关的路由比如
sw0#show ip route                                     #发现多出来下面的3条路由
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
中间省略
C    192.168.91.0/24 is directly connected, Vlan91
C    192.168.92.0/24 is directly connected, Vlan92
C    192.168.93.0/24 is directly connected, Vlan93

 

###########################################################
端口相关
二层端口
3560的所有端口缺省的端口都是二层口,分为access port 只能属于一个VLAN ;trunk port 可以让多个VLAN通信.不属于任何VLAN,
如果此端口已经配置成三层端口的话,则需要用switchport来使其成为二层端口!
三层端口
Cisco三层交换机提供两种类型的三层端口,即逻辑三层vlan端口和物理三层端口(也叫路由口):
逻辑三层vlan端口整合了路由和桥接功能,用于实现vlan之间的线速路由!
物理三层端口,可以在三层交换机上实现类似传统路由的功能,实现端口间的路由,no switchport 命令把二层口转变为三层口的,可以直接配置IP地址!

#第三个例子
步骤
1 为sw2(三层)交换机,划分7个vlan (vlan11 - vlan17)并分配端口,创建vlan接口并分配ip地址。
2 为sw2交换机指定一个三层口(路由口),并配置ip地址。
3 sw2交换机添加一条静态路由,0.0.0.0/0 下一跳地址为192.168.0.2 (sw1交换机)。
4 sw1(核心)交换机添加7条静态路由,对应sw2交换机上的vlan11 - vlan17 ip地址,下一跳地址为 192.168.0.3(sw2交换机)。

5 sw1交换机与sw2交换机级联的端口加入同一个vlan中,这里为vlan200,否则不通。
6 打开dhcp中继,并指定vlan 11 - vlan 17 dhcp ip 地址。


#1 vlan, vlan interface, ip address
sw2#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
sw2(config)#vlan 11                                       #创建并进入vlan视图
sw2(config-vlan)#vlan 12                                  #在vlan视图下,还可以创建其它vlan
sw2(config-vlan)#vlan 13
sw2(config-vlan)#vlan 14
sw2(config-vlan)#vlan 15
sw2(config-vlan)#vlan 16
sw2(config-vlan)#vlan 17
sw2(config-vlan)#exit                                     #退出vlan视图
 
sw2(config)#int fa 0/1                                    #进入端口视图
sw2(config-if)#switchport access vlan 11                  #设置此端口为vlan 11
sw2(config-if)#exit                                   #退出端口视图
sw2(config)#int fa 0/2                                    
sw2(config-if)#sw acc vlan 12                             #注意缩写命令了
sw2(config-if)#exit
sw2(config)#int fa 0/3
sw2(config-if)#sw acc vlan 13
sw2(config-if)#exit
sw2(config)#int fa 0/4
sw2(config-if)#sw acc vlan 14
sw2(config-if)#exit
sw2(config)#int fa 0/5
sw2(config-if)#sw acc vlan 15
sw2(config-if)#exit
sw2(config)#int fa 0/6
sw2(config-if)#sw acc vlan 16
sw2(config-if)#exit
sw2(config)#int fa 0/7
sw2(config-if)#sw acc vlan 17
sw2(config-if)#exit                                        #退出端口视图 

sw2(config)#int vlan 11                                    #创建并进入vlan接口视图
sw2(config-if)#ip add 192.168.11.1 255.255.255.0           #指定接口ip地址
sw2(config-if)#exit
sw2(config)#int vlan 12
sw2(config-if)#ip add 192.168.12.1 255.255.255.0
sw2(config-if)#exit
sw2(config)#int vlan 13
sw2(config-if)#ip add 192.168.13.1 255.255.255.0
sw2(config-if)#exit
sw2(config)#int vlan 14
sw2(config-if)#ip add 192.168.14.1 255.255.255.0
sw2(config-if)#exit
sw2(config)#int vlan 15
sw2(config-if)#ip add 192.168.15.1 255.255.255.0
sw2(config-if)#exit
sw2(config)#int vlan 16
sw2(config-if)#ip add 192.168.16.1 255.255.255.0
sw2(config-if)#exit
sw2(config)#int vlan 17
sw2(config-if)#ip add 192.168.17.1 255.255.255.0
sw2(config-if)#exit                                        #退出vlan接口视图


#2 configure layer 3 port
sw2(config)#int fa 0/23                                    #进入端口视图
sw2(config-if)#no switchport                               #设置当前端口为三层口
sw2(config-if)#ip address 192.168.0.3 255.255.255.0        #给三层口设置ip地址
sw2(config-if)#no shutdown                                 #开启端口
sw2(config-if)#exit                                        #退出端口视图

   
#3 sw2 static route
sw2(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2           #添加默认路由,没有匹配的转给sw1


#4 sw1 static route                                        #192.168.11.0-192.168.17.0 转给sw2
sw0(config)#ip route 192.168.11.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.12.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.13.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.14.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.15.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.16.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.17.0 255.255.255.0 192.168.0.3

 

#5 sw1 级联的端口加入到vlan
sw0(config)#int fa 0/23
sw0(config-if)#switchport access vlan 200                  #如果不加入同一个vlan,sw1与sw2无法互通
sw0(config-if)#end                                         #直接返回到全局模式
 


#6 dhcp relay                           
sw2(config)#ip dhcp excluded-address 192.168.0.1          #设置 dhcp 服务器ip地址 (Configure DHCP server or relay parameters)
sw2(config)#int vlan 11                                   #进入vlan 接口视图
sw2(config-if)#ip helper-address 192.168.0.1              #指定广播的目的地址ip (Specify a destination address for UDP broadcasts)
sw2(config-if)#exit                                       #退出vlan接口视图
sw2(config)#int vlan 12
sw2(config-if)#ip helper-address 192.168.0.1 
sw2(config-if)#exit
sw2(config)#int vlan 13
sw2(config-if)#ip helper-address 192.168.0.1 
sw2(config-if)#exit
sw2(config)#int vlan 14
sw2(config-if)#ip helper-address 192.168.0.1 
sw2(config-if)#exit
sw2(config)#int vlan 15
sw2(config-if)#ip helper-address 192.168.0.1 
sw2(config-if)#exit
sw2(config)#int vlan 16
sw2(config-if)#ip helper-address 192.168.0.1
sw2(config-if)#exit
sw2(config)#int vlan 17
sw2(config-if)#ip helper-address 192.168.0.
sw2(config-if)#exit                                      #退出vlan接口视图

小结

1 三层交换机 no switchport 命令可以指定某端口为三层口, 可以直接添加ip地址。

2 三层交换机之间级联的端口需在同一个vlan中,否则不通。

############################################################

其它

sw9#write                                              #保存配置信息
sw9#write erase                                        #是清除启动配置 startup-config
sw9(config-if)#end                                     #直接返回到全局模式              
sw9#reload                                             #重新载入配置
sw9#?                                                  #键入 ? 获取该视图下所有的命令及其简单描述
sw9#conf?                                              #显示匹配的完整命令
configure
sw9#enable password  123456                            #设置登录密码
sw9#show version                                       #查看版本及引导信息
sw9#show running-config                                #查看运行设置
sw9#show startup-config                                #查看开机设置



本文转自 dongnan 51CTO博客,原文链接: http://blog.51cto.com/dngood/607320

相关文章
|
4天前
|
算法 网络协议 Linux
【Cisco Packet Tracer】交换机的自学习算法
【Cisco Packet Tracer】交换机的自学习算法
63 0
|
4天前
|
监控 数据安全/隐私保护 网络虚拟化
ensp命令练习及交换机 和个路由器的基本命令
ensp命令练习及交换机 和个路由器的基本命令
154 0
|
4天前
|
网络协议 Linux 网络架构
【Cisco Packet Tracer】集线器和交换机区别
【Cisco Packet Tracer】集线器和交换机区别
109 1
|
4天前
|
网络协议 网络性能优化 网络虚拟化
【亮剑】介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置
【4月更文挑战第30天】本文介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置。通过这些命令,网络工程师可以有效地管理设备、优化网络性能并解决网络问题。熟练掌握这些命令对于提升网络运行效率至关重要。
|
7月前
|
算法 网络虚拟化 C语言
【Cisco Packet Tracer】交换机划分Vlan实验
文章目录 一、前期准备 二、实验要求 三、搭建局域网 四、配置pc端的ip 五、配置VLAN 六、设置端口模式trunk 七、PING检验是否通路
|
12月前
|
监控 网络虚拟化 数据安全/隐私保护
ensp命令练习及交换机 和个路由器的基本命令(下)
ensp命令练习及交换机 和个路由器的基本命令
|
12月前
|
监控 数据安全/隐私保护 网络虚拟化
ensp命令练习及交换机 和个路由器的基本命令(上)
ensp命令练习及交换机 和个路由器的基本命令
|
存储 网络协议 算法
华为三层交换机命令集合,已经分好类了,网工建议收藏!
华为三层交换机命令集合,已经分好类了,网工建议收藏!
344 0
|
网络协议 Shell 网络虚拟化
ospf,三层交换机,热备,以太网通道练习实验(含命令)
ospf,三层交换机,热备,以太网通道练习实验(含命令)
109 0
ospf,三层交换机,热备,以太网通道练习实验(含命令)
|
安全 Shell 网络虚拟化
三层交换机(三层配置基础命令)
三层交换机(三层配置基础命令)
338 0
三层交换机(三层配置基础命令)