hdu 1686 Oulipo【kmp】

简介: Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'.
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
 
 
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
 
 
1 3 0
 
题目翻译:看样例吧,没什么翻译的

#include <cstdio>
#include <cstring>
#define maxn 10005
int next[maxn], len1, len2;
char str[maxn], buf[maxn * 100];
void getNext() {
    len1=strlen(str);
    len2=strlen(buf);
	int i = 0, j = -1;
	next[i] = j;
	while(i < len1) {
		if(j == -1 || str[i] == str[j]) {
			++i; ++j;
            next[i] = j;
		}
		else j = next[j];
	}
}
int KMP() {
	getNext();
	int i = 0, j = 0, cnt = 0;
	while(i < len2) {
		if(j == -1 || buf[i] == str[j]) {
			++i; ++j;
			if(j == len1) cnt++;
		}
		else j = next[j];
	}
	return cnt;
}
int main() {
    int T;
    scanf("%d",&T);
	while(T--) {
        scanf("%s%s",str,buf);
		printf("%d\n",KMP());
	}
	return 0;
}

目录
相关文章
|
4月前
|
Java
HDU-1686-Oulipo
HDU-1686-Oulipo
21 0
|
4月前
|
机器学习/深度学习
N皇后问题(HDU—2253)
N皇后问题(HDU—2253)
|
存储 C++
【PAT甲级 - C++题解】1075 PAT Judge
【PAT甲级 - C++题解】1075 PAT Judge
60 0
HDOJ(HDU) 1465 不容易系列之一(错排)
HDOJ(HDU) 1465 不容易系列之一(错排)
81 0
ZOJ 1403&&HDU 1015 Safecracker【暴力】
Safecracker Time Limit: 2 Seconds      Memory Limit: 65536 KB === Op tech briefing, 2002/11/02 06:42 CST === "The item is locked in a Klein safe behind a painting in the second-floor library.
1204 0
|
索引
字符串hash - POJ 3461 Oulipo
Oulipo  Problem's Link ---------------------------------------------------------------------------- Mean:  给你一个模式串P和一个母串S,让你统计P串在S串中出现的次数.
851 0
数论 - 筛法暴力打表 --- hdu : 12876 Quite Good Numbers
Quite Good Numbers Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB Total submit users: 77, Accepted users: 57 P...
973 0