HDOJ 1096 A+B for Input-Output Practice (VIII)

简介: Problem Description Your task is to calculate the sum of some integers.Input Input contains an integer N in the first line, and then N lines follow.

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

import java.util.*;
class Main{
    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);
        boolean isFirst = true;
        int m=sc.nextInt();
        while(m-->0){
            int n=sc.nextInt();
            int sum=0;
            for(int i=0;i<n;i++){
            int a=sc.nextInt();
            sum+=a;
            }
            if(isFirst){
                isFirst=false;
            }else{
                System.out.println();
            }
            System.out.println(sum);
        }
    }
}
目录
相关文章
A+B for Input-Output Practice
A+B for Input-Output Practice
HDOJ 1096 A+B for Input-Output Practice (VIII)
HDOJ 1096 A+B for Input-Output Practice (VIII)
99 0
HDOJ 1095 A+B for Input-Output Practice (VII)
HDOJ 1095 A+B for Input-Output Practice (VII)
102 0
HDOJ 1093 A+B for Input-Output Practice (V)
HDOJ 1093 A+B for Input-Output Practice (V)
89 0
HDOJ 1089 A+B for Input-Output Practice (I)
HDOJ 1089 A+B for Input-Output Practice (I)
107 0
HDOJ 1091 A+B for Input-Output Practice (III)
HDOJ 1091 A+B for Input-Output Practice (III)
95 0
HDOJ 1090 A+B for Input-Output Practice (II)
HDOJ 1090 A+B for Input-Output Practice (II)
87 0