[分享]错误“应用程序Xcode的这个版本不能与此版本的OS X配合使用”以及Mac源码和IOS开发资料分享-阿里云开发者社区

开发者社区> 安全> 正文

[分享]错误“应用程序Xcode的这个版本不能与此版本的OS X配合使用”以及Mac源码和IOS开发资料分享

简介: [分享]错误“应用程序Xcode的这个版本不能与此版本的OS X配合使用”以及Mac源码和IOS开发资料分享 安装Xcode时,出现“应用程序Xcode的这个版本不能与此版本的OS X配合使用”错误如下: 解决方案是: /system/libary/coreservice/SystemVersion.plist中的两个10.10为10.10.5 修改过程会提示无权限修改,要不要建立副本,点击提示框中的“复制”按钮,存到桌面上。

[分享]错误“应用程序Xcode的这个版本不能与此版本的OS X配合使用”以及Mac源码和IOS开发资料分享


安装Xcode时,出现“应用程序Xcode的这个版本不能与此版本的OS X配合使用”错误如下:


解决方案是:

/system/libary/coreservice/SystemVersion.plist中的两个10.10为10.10.5

修改过程会提示无权限修改,要不要建立副本,点击提示框中的“复制”按钮,存到桌面上。

点击一个文件右键选“显示简介”,在简介窗口中可以解锁和修改用户权限如下图所示:


解锁后设置everyone为可读写,然后把桌面上的副本文件SystemVersion.plist粘帖替换到/system/libary/coreservice/SystemVersion.plist,这里需要管理员权限输入密码确定即可。

替换完一定要重启机器,否是还是会提示那个错误。

重启完就可以安装使用了:



Mac源码:http://opensource.apple.com/release/os-x-1011/

Xcode源码官方例子:https://developer.apple.com/library/ios/navigation/#section=Resource%20Types&topic=Sample%20Code

IOS开发:http://www.tutorialspoint.com/ios/index.htm

Object-C开发:http://www.tutorialspoint.com/objective_c/index.htm

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
+ 订阅

云安全开发者的大本营

其他文章