2024网络建设与运维赛题-网络配置教程

简介: 某集团公司的网络由北京总公司的SW1、SW2、SW3,上海分公司的SW及长沙办事处的设备互联,采用神州数码的DCR-2855路由器、CS6200-28X-Pro三层交换机、DCWS-6028-Pro无线交换机和DCFW-1800E-N3002-Pro防火墙。IP配置包括多个VLAN及Tunnel,如SW1的10.0.1.1/32、RT1的10.0.5.1/32等。FW1和FW2作为边界防火墙,提供不同区域的访问控制。配置示例展示了SW1、SW2和SW3的接口IP分配。

项目简介:

某集团公司原在北京建立了总公司,后在上海建立了分公司,又在长沙建立了办事处。集团全网采用路由协议进行互联互通。
总公司、分公司、办事处、Internet的网络结构详见拓扑图。编号为SW1、SW2、SW3的设备作为总公司核心交换机;编号FW1的设备作为总公司互联网出口防火墙;编号为FW2的设备作为分公司互联网出口防火墙;编号为RT1的设备作为互联网出口路由器;编号为RT2的设备作为办事处路由器;编号为AC1的设备作为无线控制器,通过与办事处AP1配合实现所属区域无线覆盖。

image.png

本次使用设备:神州数码产品线

  • 路由器:DCR-2855
  • 三层交换机:CS6200-28X-Pro
  • 无线交换机:DCWS-6028-Pro
  • 多核防火墙:DCFW-1800E-N3002-Pro

    注:本文章IP配置不涉及VRF部分配置,VRF部分请看我的其他文章。

网络设备IP地址分配表

设备名称 设备接口 IP地址
SW1 Loopback1 10.0.1.1/32
Vlan11 10.0.11.1/24
Vlan12 10.0.12.1/24
Vlan13 10.0.13.1/24
Vlan14 10.0.14.1/24
Vlan1019 10.0.255.2/30
Vlan1020 10.0.255.9/30
Vlan1022 10.0.255.17/30
SW1-BR Loopback2 10.0.1.2/32
Vlan2017 10.0.254.2/30
Vlan2018 10.0.254.9/30
SW1-IN Loopback3 20.0.1.3/32
Vlan3013 20.0.255.1/30
Vlan3014 20.0.255.13/30
Vlan3015 20.0.255.21/30
SW2 Loopback1 10.0.2.1/32
Vlan21 10.0.21.1/24
Vlan22 10.0.22.1/24
Vlan23 10.0.23.1/24
Vlan24 10.0.24.1/24
Vlan1019 10.0.255.6/30
Vlan1020 10.0.255.13/30
Vlan1022 10.0.255.18/30
SW2-BR Loopback2 10.0.2.2/32
Vlan2017 10.0.254.6/30
Vlan2018 10.0.254.13/30
SW2-IN Loopback3 20.0.2.3/32
Vlan3013 20.0.255.14/30
Vlan3014 20.0.255.17/30
Vlan3015 20.0.255.25/30
SW3 Loopback1 10.0.3.1/32
Vlan31 10.0.31.1/24
Vlan32 10.0.32.1/24
Vlan33 10.0.33.1/24
Vlan34 10.0.34.1/24
Vlan1019 10.0.255.10/30
Vlan1020 10.0.255.14/30
SW3-BR Loopback2 10.0.3.2/32
Vlan2017 10.0.254.10/30
Vlan2018 10.0.254.14/30
SW3-IN Loopback3 20.0.3.3/32
Vlan3013 20.0.255.10/30
Vlan3014 20.0.255.18/30
Vlan3015 20.0.255.29/30
AC1 Loopback1 10.0.4.1/32
Vlan50 10.0.50.1/24
Vlan60 10.0.60.1/24
Vlan1001 10.0.253.6/30
RT1 Loopback1 10.0.5.1/32
G0/0 20.0.255.30/30
G0/1 10.0.253.1/30
Tunnel1 10.0.252.6/30
RT1-IN Loopback2 20.0.5.2/32
Loopback3 20.0.5.3/32
G0/2 20.0.255.2/30
G0/3 20.0.255.5/30
RT2 Loopback1 10.0.6.1/32
G0/0 10.0.253.2/30
G0/1 10.0.253.5/30
RT2-IN Loopback2 20.0.6.2/32
Loopback3 20.0.6.3/32
G0/2 20.0.255.6/30
G0/3 20.0.255.9/30
FW1 Loopack1(trust) RIP 10.0.7.1/32
Loopback2(trust) OSPF 10.0.7.2/32
Loopback3(trust) ISIS 10.0.7.3/32
E0/1(untrust) 20.0.255.22/30
E0/2(trust) 10.0.255.1/30
E0/3(trust) 10.0.255.5/30
Tunnel1(trust) 10.0.252.1/30
Tunnel2(trust) 10.0.252.5/30
FW2 Loopback1(trust) 10.0.8.1/32
E0/1(untrust) 20.0.255.26/30
E0/2(trust) 10.0.254.1/30
E0/3(trust) 10.0.254.5/30
Tunnel1(trust) 10.0.252.2/30
PC1 Eth0 10.0.31.10/24
PC2 Eth0 10.0.32.10/24

SW1配置

CS6200-28X-Pro>enable                                                           
CS6200-28X-Pro#config                                                           
CS6200-28X-Pro(config)#hostname SW1                                             
SW1(config)#interface loopback 1                                    
SW1(config-if-loopback1)#ip address 10.0.1.1 255.255.255.255                    
SW1(config-if-loopback1)#exit
SW1(config)#vlan 11-14;1019-1020;1022                                           
SW1(config)#interface vlan 11
SW1(config-if-vlan11)#ip address 10.0.11.1 255.255.255.0                        
SW1(config-if-vlan11)#interface vlan 12
SW1(config-if-vlan12)#ip address 10.0.12.1 255.255.255.0                        
SW1(config-if-vlan12)#interface vlan 13
SW1(config-if-vlan13)#ip address 10.0.13.1 255.255.255.0                        
SW1(config-if-vlan13)#interface vlan 14
SW1(config-if-vlan14)#ip address 10.0.14.1 255.255.255.0
SW1(config-if-vlan14)#interface vlan 1019
SW1(config-if-vlan1019)#ip add 10.0.255.2 255.255.255.252                       
SW1(config-if-vlan1019)#interface vlan 1020
SW1(config-if-vlan1020)#ip add 10.0.255.9 255.255.255.252                       
SW1(config-if-vlan1020)#interface vlan 1022
SW1(config-if-vlan1022)#ip add 10.0.255.17 255.255.255.252
SW1(config-if-vlan1022)#exit

SW2配置

SW2配置:
CS6200-28X-Pro>enable 
CS6200-28X-Pro#config 
CS6200-28X-Pro(config)#hostname SW2
SW2(config)#interface loopback 1
SW2(config-if-loopback1)#ip add 10.0.2.1 255.255.255.255
SW2(config-if-loopback1)#exit        
SW2(config)#vlan 21-24;1019-1020;1022
SW2(config)#interface vlan 21
SW2(config-if-vlan21)#ip add 10.0.21.1 255.255.255.0
SW2(config-if-vlan21)#interface vlan 22
SW2(config-if-vlan22)#ip add 10.0.22.1 255.255.255.0
SW2(config-if-vlan22)#interface vlan 23
SW2(config-if-vlan23)#ip add 10.0.23.1 255.255.255.0
SW2(config-if-vlan23)#interface vlan 24
SW2(config-if-vlan24)#ip add 10.0.24.1 255.255.255.0                            
SW2(config-if-vlan24)#interface vlan 1019
SW2(config-if-vlan1019)#ip address 10.0.255.6 255.255.255.252                   
SW2(config-if-vlan1019)#interface vlan 1020
SW2(config-if-vlan1020)#ip address 10.0.255.13 255.255.255.252                  
SW2(config-if-vlan1020)#interface vlan 1022
SW2(config-if-vlan1022)#ip address 10.0.255.18 255.255.255.252                  
SW2(config-if-vlan1022)#exit

SW3配置

CS6200-28X-Pro#enable                                                           
CS6200-28X-Pro#config                                                           
CS6200-28X-Pro(config)#hostname SW3                                             
SW3(config)#interface loopback 1
SW3(config-if-loopback1)#ip add 10.0.3.1 255.255.255.255                        
SW3(config-if-loopback1)#exit                                                   
SW3(config)#vlan 31-34;1019-1020
SW3(config)#interface vlan 31
SW3(config-if-vlan31)#ip address 10.0.31.1 255.255.255.0                        
SW3(config-if-vlan31)#interface vlan 32
SW3(config-if-vlan32)#ip address 10.0.32.1 255.255.255.0                        
SW3(config-if-vlan32)#interface vlan 33
SW3(config-if-vlan33)#ip address 10.0.33.1 255.255.255.0                        
SW3(config-if-vlan33)#interface vlan 34
SW3(config-if-vlan34)#ip address 10.0.34.1 255.255.255.0
SW3(config-if-vlan34)#interface vlan 1019
SW3(config-if-vlan1019)#ip address 10.0.255.10 255.255.255.252                  
SW3(config-if-vlan1019)#interface vlan 1020
SW3(config-if-vlan1020)#ip address 10.0.255.14 255.255.255.252                  
SW3(config-if-vlan1020)#exit

RT1配置

Router>enable                                                                                     
Router#config
Router_config#hostname RT1
RT1_config#interface loopback 1                                              
RT1_config_l1#ip add 10.0.5.1 255.255.255.255                                                                                   
RT1_config_l1#interface gigaEthernet 0/0
RT1_config_g0/0#ip address 20.0.255.30 255.255.255.252                       
RT1_config_g0/0#interface gigaEthernet 0/1                                   
RT1_config_g0/1#ip address 20.0.253.1 255.255.255.252                                                                       
RT1_config_g0/1#interface tunnel 1                                                                            
RT1_config_t1#ip address 10.0.252.6 255.255.255.252                                                       
RT1_config_t1#exit

RT2配置

Router>enable                                                                   
Router#config
Router_config#hostname RT2
RT2_config#interface loopback 1                                              
RT2_config_l1#ip address 10.0.6.1 255.255.255.255                            
RT2_config_l1#interface gigaEthernet 0/0                                     
RT2_config_g0/0#ip address 10.0.253.2 255.255.255.252                        
RT2_config_g0/0#interface gigaEthernet 0/1                                   
RT2_config_g0/1#ip address 10.0.253.5 255.255.255.252                        
RT2_config_g0/1#exit

FW1配置

login: admin                                                                    
password:                                                                       
DCFW-1800# configure                                                            
DCFW-1800(config)# hostname FW1                                                 
FW1(config)# interface loopback1                                                
FW1(config-if-loo1)# zone trust                                                 
FW1(config-if-loo1)# ip add 10.0.7.1/32                                         
FW1(config-if-loo1)# interface loopback2                                        
FW1(config-if-loo2)# zone trust                                                 
FW1(config-if-loo2)# ip add 10.0.7.2/32                                         
FW1(config-if-loo2)# interface loopback3                                        
FW1(config-if-loo3)# zone trust                                                 
FW1(config-if-loo3)# ip add 10.0.7.3/32                                         
FW1(config-if-loo3)# interface ethernet0/1                                                                                    
FW1(config-if-eth0/1)# zone untrust                                             
FW1(config-if-eth0/1)# ip address 20.0.255.22/30                                
FW1(config-if-eth0/1)# interface ethernet0/2                                    
FW1(config-if-eth0/2)# zone trust                                               
FW1(config-if-eth0/2)# ip address 10.0.255.1/30                                 
FW1(config-if-eth0/2)# interface ethernet0/3                                    
FW1(config-if-eth0/3)# zone trust                                               
FW1(config-if-eth0/3)# ip address 10.0.255.5/30
FW1(config-if-eth0/3)# interface tunnel1                                        
FW1(config-if-tun1)# zone trust                                                 
FW1(config-if-tun1)# ip address 10.0.252.1/30                                   
FW1(config-if-tun1)# interface tunnel2                                          
FW1(config-if-tun2)# zone trust                                                 
FW1(config-if-tun2)# ip address 10.0.252.5/30                                   
FW1(config-if-tun2)# exit

FW2配置

login: admin                                                                    
password:                                                                       
DCFW-1800# configure                                                            
DCFW-1800(config)# hostname FW2                                                 
FW2(config)# interface loopback1                                                
FW2(config-if-loo1)# zone trust                                                 
FW2(config-if-loo1)# ip address 10.0.8.1/32                                     
FW2(config-if-loo1)# interface ethernet0/1                                      
FW2(config-if-eth0/1)# zone untrust                                             
FW2(config-if-eth0/1)# ip address 20.0.255.26/30                                
FW2(config-if-eth0/1)# interface ethernet0/2                                    
FW2(config-if-eth0/2)# zone trust                                               
FW2(config-if-eth0/2)# ip address 10.0.254.1/30                                 
FW2(config-if-eth0/2)# interface ethernet0/3                                    
FW2(config-if-eth0/3)# zone trust                                               
FW2(config-if-eth0/3)# ip address 10.0.254.5/30                                         
FW2(config-if-eth0/3)# exit

AC1配置

DCWS-6028-Pro>enable                                                            
DCWS-6028-Pro#config                                                            
DCWS-6028-Pro(config)#hostname AC1                                              
AC1(config)#interface loopback 1                                                
AC1(config-if-loopback1)#ip address 10.0.4.1 255.255.255.255                     
AC1(config-if-loopback1)#exit                                                   
AC1(config)#vlan 50;60;1001                                                     
AC1(config)#interface vlan 50                                                   
AC1(config-if-vlan50)#ip address 10.0.50.1 255.255.255.252                       
AC1(config-if-vlan50)#interface vlan 60                                         
AC1(config-if-vlan60)#ip address 10.0.60.1 255.255.255.252                       
AC1(config-if-vlan60)#interface vlan 1001                                       
AC1(config-if-vlan1001)#ip address 10.0.253.6 255.255.255.252                   
AC1(config-if-vlan1001)#exit
相关文章
|
16天前
|
运维 网络协议 网络安全
2023网络建设与运维正式赛卷-IP地址分配-下
【7月更文挑战第1天】该集团进行数字化转型,构建了两地三中心的网络架构,包括城市A的两个数据中心(SW1、SW2为核心交换机)和城市C的灾备数据中心(SW3)。使用OSPF、RIP、ISIS、BGP路由协议实现全网互联。RT1和RT2为总部分公司间的路由器,FW1作为总公司互联网出口防火墙,FW2为办事处防火墙。IP地址表详细列出了各设备接口的IPv4和IPv6地址。本文配置示例了路由器和防火墙的接口设置。
2023网络建设与运维正式赛卷-IP地址分配-下
|
15天前
|
存储 缓存 网络协议
网络编程初学者必备:从零开始的详细教程与资源汇总
网络编程初学者必备:从零开始的详细教程与资源汇总
|
14天前
|
运维 网络协议 网络安全
2023网络建设与运维正式赛卷-交换配置
【7月更文挑战第3天】某集团构建了两地三中心网络架构,包括两个数据中心和异地灾备中心,使用OSPF、RIP、ISIS、BGP协议互联。核心设备包括SW1、SW2(数据中心)、SW3(灾备及办事处),以及FW1(总司防火墙)、FW2(办事处防火墙)等。网络拓扑涉及多个VLAN和IP地址段,SW3配置了VRF隔离办事处和Internet流量。SW1配置SNMPv3用于监控,并设置流量镜像。链路故障检测和LLDP启用以确保网络健康。
|
15天前
|
运维 网络协议 网络安全
2023网络建设与运维正式赛卷-交换配置-上
【7月更文挑战第2天】该集团进行数字化转型,构建了两地三中心网络架构,包括两个数据中心和一个异地灾备中心。网络使用OSPF、RIP、ISIS、BGP协议互联,并设有多台交换机、路由器、防火墙和无线控制器。例如,SW1和SW2为核心交换机,SW3为灾备DC的核心交换机,FW1为总公司防火墙,FW2为办事处防火墙,RT1和RT2为路由器,AC1为有线无线控制器。配置中涉及VLAN隔离、端口访问控制、LACP聚合、负载均衡和IPSec VPN,以确保网络稳定性、安全性和可扩展性。已完成的配置需通过客户端测试验证功能正常。
|
17天前
|
Linux 网络安全 数据安全/隐私保护
网络安全教程-------渗透工具Kali,官网链接,ARM的介绍,Mobil,华为小米,oppe手机,是无法刷入第三方的操作系统的,E+手机,谷歌的picksoul,或者三星手机,系统盘是WSL的
网络安全教程-------渗透工具Kali,官网链接,ARM的介绍,Mobil,华为小米,oppe手机,是无法刷入第三方的操作系统的,E+手机,谷歌的picksoul,或者三星手机,系统盘是WSL的
|
18天前
|
存储 Java
黑马全套Java教程(九):网络编程(四)
黑马全套Java教程(九):网络编程
18 0
|
18天前
|
网络协议 Java
黑马全套Java教程(九):网络编程(三)
黑马全套Java教程(九):网络编程
11 0
|
18天前
|
Java
黑马全套Java教程(九):网络编程(二)
黑马全套Java教程(九):网络编程(二)
12 0
|
3天前
|
Shell Linux C语言
|
1天前
|
网络协议 Ubuntu Linux

热门文章

最新文章