node-sass与node版本不匹配问题解决方法

简介: node-sass与node版本不匹配问题解决方法


下载前准备

①查看本地nodejs的版本

node -v

②查看node版本对应的node-sass版本

比如上面我的node是v16.15.0,我找到对应的node-sass版本

③node-sass所有版本

去npm官网 https://www.npmjs.com/package/node-sass

看到6.x版本可以下载6.0.0和6.01

前端项目安装依赖

①install node-sass

cnpm install node-sass@6.0.1

②安装其他依赖

cnpm install

③启动项目

npm run dev


大功告成!!

相关文章
|
30天前
|
JavaScript 内存技术
node与npm版本对应关系以及使用nvm管理node版本
node与npm版本对应关系以及使用nvm管理node版本
111 0
|
20天前
|
JavaScript 内存技术
不同版本NodeJS切换使用
不同版本NodeJS切换使用
11 0
|
27天前
|
内存技术
node版本与npm版本不对应的解决方案
node版本与npm版本不对应的解决方案
22 0
|
2月前
|
JavaScript 前端开发 算法
【Node.js 版本过高】运行前端时,遇到错误 `Error: error:0308010C:digital envelope routines::unsupported`
【Node.js 版本过高】运行前端时,遇到错误 `Error: error:0308010C:digital envelope routines::unsupported`
64 0
|
2月前
|
JavaScript
查看NodeJs版本和查看NPM版本
查看NodeJs版本和查看NPM版本
47 0
查看NodeJs版本和查看NPM版本
|
2月前
nodejs17/18版本报错:digital envelope routines::unsupported
nodejs17/18版本报错:digital envelope routines::unsupported
39 0
|
2月前
|
缓存 JavaScript
mac升级node到指定版本
mac升级node到指定版本
|
2月前
|
JavaScript 内存技术
nvm安装和切换node使用版本
nvm安装和切换node使用版本
|
2月前
|
Ubuntu Unix Linux
node-sass版本适配问题
node-sass版本适配问题
30 0
|
3月前
|
JavaScript Linux iOS开发
nodejs最新版本安装
【1月更文挑战第16天】nodejs最新版本安装
39 4