ensp 实现三层交换机和单臂路由之间的通信

简介: ensp 实现三层交换机和单臂路由之间的通信

c583ba108f8f4131856c491c4930d561.png


1 对于三层交换机之间的配置


LSW2
创建vlan
[dly]vlan batch 20 30 40
[dly-Ethernet0/0/2]port link-type access 端口类型的更改
[dly-Ethernet0/0/2]port default vlan 20 端口pvid的设置
[dly-Ethernet0/0/3]port link-type access 端口类型的更改
[dly-Ethernet0/0/3]port default vlan 20 端口pvid的设置
[dly-Ethernet0/0/4]port link-type access 端口类型的更改
[dly-Ethernet0/0/4]port default vlan 30 端口pvid的设置
[dly-Ethernet0/0/5]port link-type access 端口类型的更改
[dly-Ethernet0/0/5]port default vlan 30 端口pvid的设置
[dly-Ethernet0/0/1]port link-type access 端口类型的更改
[dly-Ethernet0/0/1]port default vlan 40 端口pvid的设置

191a74c2832d4ec49a98f316a749d01f.png


LSW2
引入vlanif
[dly-Vlanif20]ip ad 192.168.2.254  24
[dly-Vlanif30]ip ad 192.168.3.254 24
[dly-Vlanif40]ip ad 27.1.1.2 24  
27.1.1.0 是交换机和路由器之间自定义的网段


不同网段之间想要实现通信,可以利用ospf来实现
LSW2 宣告网段
[dly-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[dly-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
[dly-ospf-1-area-0.0.0.0]network 27.1.1.0 0.0.0.255
R7 宣告网段
[dly-ospf-1-area-0.0.0.0]network 75.1.1.0 0.0.0.255
75.1.1.0 是两个路由器之间定义的网段
[dly-ospf-1-area-0.0.0.0]network 27.1.1.0 0.0.0.255

d61ec648fb004e3c94ae9b9764ef2062.png


6324f96b1e124c04aa3edf47d1892ad1.png


2 单臂路由的配置


LSW3
[dly]vlan batch 40 50 创建vlan
[dly-Ethernet0/0/1]port link-type access
[dly-Ethernet0/0/1]port default vlan 40
[dly-Ethernet0/0/2]port link-type access
[dly-Ethernet0/0/2]port default vlan 50
[dly-Ethernet0/0/3]port link-type trunk
[dly-Ethernet0/0/3]port trunk allow-pass vlan 40 50


R5
[dly-Ethernet0/0/0]ip ad 75.1.1.5 24
[dly-Ethernet0/0/1.1]ip ad 192.168.4.254 24 
[dly-Ethernet0/0/1.1]dot1q termination vid 40
[dly-Ethernet0/0/1.1]arp broadcast enable
[dly-Ethernet0/0/1.2]ip ad 192.168.5.254 24
[dly-Ethernet0/0/1.2]dot1q termination vid 50
[dly-Ethernet0/0/1.2]arp broadcast enable


路由器R5的网段宣告 
[dly-ospf-1-area-0.0.0.0]network 75.1.1.0 0.0.0.25
[dly-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
[dly-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255


3ping命令测试通信结果


5f002c9474394b76a91cc3aaa7e2f459.png


8c3052b2f9da426788246d4074a4a60f.png

c3b4327004474144b4822c3fb3e6976b.png


三层交换机应运而生。三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。


通过划分VLAN,可以有效隔离广播,一个vlan就是一个独立的广播域,广播以及数据帧的泛洪被限制在vlan内部,不同vlan之间二层隔离。但是实际的网络中时常需要vlan之间通信,因此要实现vlan之间的通信,就需要通过三层设备(具有路由功能的设备)来实现。


VLANIF(Virtual Local Area Network Interface),是华为交换机的一个配置项,应用于三层交换机。这是一种逻辑接口,物理上不存在。


在配置好二层vlan后,三层交换机上使用vlanif命令建立对应vlan的路由,配置完成后,可以实现VLAN之间的通信。

相关文章
|
1月前
|
SDN 网络虚拟化 网络架构
在单交换机局域网中,不同网段的主机通信探秘🌐
在理解局域网中不同网段主机之间的通信之前,我们首先要明白网络的基本组成和工作原理。局域网(LAN)是一个封闭的网络环境,通常由交换机(Switch)作为核心设备连接网络中的各个主机。当我们谈论不同网段的主机时,实质上是在讨论它们配置的IP地址属于不同的IP地址范围。现在,**假设我们有两台主机(主机A和主机B),它们连接到同一个交换机,但配置在不同的网段上。问题来了:这两台主机能够直接通信吗**?🤔
在单交换机局域网中,不同网段的主机通信探秘🌐
|
1月前
|
安全 数据处理 网络虚拟化
|
1月前
|
网络协议 算法 安全
|
1月前
|
网络协议 算法 网络虚拟化
|
1月前
|
JavaScript 网络虚拟化 网络架构
路由器只能连接不同网段的设备,隔离广播域,交换机可以连接不同网段,也可以连接相同网段(三层) 二层只能同网段
路由器只能连接不同网段的设备,隔离广播域,交换机可以连接不同网段,也可以连接相同网段(三层)二层只能同网段
25 1
|
1月前
|
网络协议 网络性能优化 网络虚拟化
【亮剑】介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置
【4月更文挑战第30天】本文介绍了华为三层交换机的配置命令,包括基本配置(系统启动、接口配置、基础设置)、路由协议(OSPF、BGP)配置和高级功能(VLAN、ACL、QoS)配置。通过这些命令,网络工程师可以有效地管理设备、优化网络性能并解决网络问题。熟练掌握这些命令对于提升网络运行效率至关重要。
|
1月前
|
网络虚拟化 网络架构
三层交换机对接路由器配置上网实验
三层交换机简介 三层交换机是具有路由功能的交换机,由于路由属于OSI模型中第三层网络层的功能,所以称为三层交换机。 三层交换机既可以工作在二层也可以工作在三层,可以部署在接入层,也可以部署在汇聚层,作为用户的网关。
|
1月前
|
缓存 网络协议 安全
使用 eNSP 模拟交换机防御 ARP 泛洪
使用 eNSP 模拟交换机防御 ARP 泛洪攻击
|
1月前
|
消息中间件 Java Maven
springboot 使用注解的方式创建rabbitmq的交换机、路由key、以及监听队列的名称
springboot 使用注解的方式创建rabbitmq的交换机、路由key、以及监听队列的名称
|
1月前
|
网络性能优化 网络虚拟化 网络架构
配置接口限速示例(盒式交换机)
接口限速简介 接口限速对通过整个端口的全部报文流量速率进行限制,不对具体流量进行区分,可以实现给某个接口分配固定的带宽,控制方式单一,配置简单。 入方向与出方向的接口限速属于并列关系,用户可以根据需要同时配置,也可以单独配置。