windows系统上已配置jdk1.7,想再加个jdk1.8应该怎么配置 :报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

windows系统上已配置jdk1.7,想再加个jdk1.8应该怎么配置 :报错

kun坤 2020-06-20 13:48:32 2081

想学习一个项目,那个项目要求jdk1.8,但是电脑上已经装了jdk1.7,而且公司项目用的这个,怕乱配搞出了问题

Windows
分享到
取消 提交回答
全部回答(2)
  • kun坤
    2020-06-20 13:48:39

    引用来自“跬步至千里”的评论

    Idea和eclipse项目都可以单独指定用哪个jdk。

    那么我直接安装jdk1.8然后在eclipse里指定就可以了吗

     

    ######可以的,甚至你安装jdk1.8,maven里配置不同jdk版本都可以######就把java_home环境变量的路径改一下的事儿######可以安装两个jdk,想用哪个就改环境变量!######

    引用来自“木有龙井茶”的评论

    就把java_home环境变量的路径改一下的事儿

    两个jdk都想用,一个公司项目,一个自学项目

    ######对######回复 @木有龙井茶 : 也就是说我直接安装JDK1.8,然后在IDE里设置就行了,不用管环境变量什么的######项目用哪个jdk可以在IDE里设置,java_home只是提供一个默认设置######

    引用来自“星汉”的评论

    可以安装两个jdk,想用哪个就改环境变量!

    每次都要重新改一遍吗,我在网上搜索到的好像没这么麻烦

    ######

    1. 如果使用ide的话,直接改项目使用的jdk,各个项目可以分别指定,不影响;

    2. 如果不是ide,配置java全路径

    ######eclipse创建项目的时候有三个选择jdk的方式,你可以看一下!######回复 @星汉 : eclipse和idea都不自带jdk,都需要自己指定######一般ide自带的jdk容易出问题######Idea和eclipse项目都可以单独指定用哪个jdk。######还有一个方案,如果你的电脑配置够高的话,再装一个win系统的虚拟机,在里面装1.8,学习的时候用虚拟机,这就两不耽误了######

    只要JDK8就可以。

    ######

    引用来自“蓝水晶飞机”的评论

    只要JDK8就可以。

    直接安装就可以吗

    ######是的。装好之后在项目的JDK版本里面指定JDK路径。
    0 0
添加回答
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题