tennotv
Warframe YouTube Content
Last updated a year ago by aliasfalse .
Apache-2.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install tennotv 
SYNC missed versions from official npm registry.

Tenno.tv

Greenkeeper badge Build Status semantic-release Supported by the Warframe Community Developers Discord

Contribute

If you have any interest in contributing or any feature requests, feel free to add an issue or feature request, and if you'd like to implement it, feel free to give it a shot.

Prerequisite

In order to run your own version of Warframe Hub, you are required to have the following on your machine:

  • Node 8.x for running the project
  • NPM 5.x for dependency control, usually installed with Node.js

Dependencies

Most software related dependencies should be managed by NPM, and will be automatically installed when you try to run the project. We'll cover those dependencies in the following section.

Tenno.tv relies on connection to the internet as we include data from an outside api.

Installation

Clone or download and unpack this repository. Install the dependencies using NPM

$ npm install

If everything goes well, it should tell you the number of packages it has installed. Then you can try to run it and hope everything goes well.

$ npm start

The express website should be accessible at http://localhost:3000

Bug/Issue Report

Found a bug or an issue? Please submit a bug/issue report under the issue tab.

Testing

Our builds goes through Travis-CI's tester.

You can see the latest results here or by clicking on the badge at the top of the page.

The repo also includes a mocha script that is used for Travi CI's unit testing. You can run this manually by installing mocha first globally on your machine, then run the specifications named mochaspec.js

$ npm install -g mocha
$ mocha spec mochaspec.js

Another things that's very helpful for development is nodemon. This will automatically restart the express server if any changes is detected in the project folder. No more restarting the node server manually! Just run it in the project directory and it should take care of the rest.

$ npm install -g nodemon
$ nodemon

License

The distribution of this software is protected under Apache License 2.0

Current Tags

  • 1.2.6                                ...           latest (a year ago)

9 Versions

  • 1.2.6                                ...           a year ago
  • 1.2.5                                ...           2 years ago
  • 1.2.4                                ...           2 years ago
  • 1.2.3                                ...           2 years ago
  • 1.2.2                                ...           2 years ago
  • 1.2.1                                ...           2 years ago
  • 1.2.0                                ...           2 years ago
  • 1.1.0                                ...           2 years ago
  • 1.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (22)
Dev Dependencies (10)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |