specify-dsl-bdd
BDD EDSL for the Specify framework.
Last updated 6 years ago by killdream .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install specify-dsl-bdd 
SYNC missed versions from official npm registry.

specify-dsl-bdd

NPM version Dependencies status Licence Experimental API

BDD EDSL for the Specify framework.

Example

var core = require('specify-core');
// or .promise(core) if using Promises/A+, .future(core) if using Data.Future
var spec = require('specify-dsl-bdd').node(core);

var test = spec('Root spec', function(it, spec) {
  it('Should succeed', function(){ });
  spec('More things', function(it, spec) {
    this.async('Should fail', function(done) {
      done(new Error());
    })
  })
})

Installation

$ npm install specify-dsl-bdd

Licence

Copyright (c) 2013-2014 Origami Tower.

This module is part of the Specify framework, and released under the MIT licence.

Current Tags

  • 0.2.0                                ...           latest (6 years ago)

1 Versions

  • 0.2.0                                ...           6 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (5)
Dev Dependencies (8)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |