react-native-dji-mobile
A React Native wrapper for DJI's Mobile SDK.
Last updated 9 months ago by mike_wootz .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install react-native-dji-mobile 
SYNC missed versions from official npm registry.

react-native-dji-mobile

A React Native wrapper for the DJI Mobile SDK.

Developed by Aerobotics

Please note that this project is still in its infancy. Many SDK features are not yet available, and the implementation of available features may still change. Use in your production application at your own risk!

Installation

Install the library to your project

npm i --save react-native-dji-mobile

iOS

Using Cocoapods (recommended)

  1. First link the library
react-native link react-native-dji-mobile
  1. The library requires the manual installation of the DJIWidget pod, used to display live video feed from the drone.

    1. Add use_modular_headers! to the top of your podfile.

    2. Add the following dependency to your podfile:

    + pod 'DJIWidget', '~> 1.5', :modular_headers => false
      pod 'react-native-dji-mobile', :path => '../node_modules/react-native-dji-mobile'
    
    1. Add :modular_headers => false to the pod dependencies for DoubleConversion, glog, and Folly in your podfile.

    After applying these changes your podfile should look similar to this:

    platform :ios, '9.0'
    
    target '[YourProjectName]' do
      use_modular_headers!
    
      ...
    
      # Pods for [YourProjectName]
      pod 'React', :path => '../node_modules/react-native', :subspecs => [
        'Core',
        'CxxBridge', # Include this for RN >= 0.47
        'DevSupport', # Include this to enable In-App Devmenu if RN >= 0.43
        'RCTText',
        'RCTNetwork',
        'RCTWebSocket', # needed for debugging
        # Add any other subspecs you want to use in your project
      ]
      # Explicitly include Yoga if you are using RN >= 0.42.0
      pod "yoga", :path => "../node_modules/react-native/ReactCommon/yoga"
    
      # Third party deps podspec link
      pod 'DoubleConversion', :podspec => '../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec', :modular_headers => false
      pod 'glog', :podspec => '../node_modules/react-native/third-party-podspecs/glog.podspec', :modular_headers => false
      pod 'Folly', :podspec => '../node_modules/react-native/third-party-podspecs/Folly.podspec', :modular_headers => false
    
      pod 'DJIWidget', '~> 1.5', :modular_headers => false
      pod 'react-native-dji-mobile', :path => '../node_modules/react-native-dji-mobile'
    
      ...
    
    end
    
  2. run pod install to ensure the required dependencies are installed

  3. To ensure that the library will build, you must add Swift support to your Xcode project:

    1. Open ios/YourAppName.xcworkspace
    2. Select File > New > File... in Xcode's menu bar or press <kbd>CMD</kbd>+<kbd>N</kbd>.
    3. Add a new Swift file to your project, and when asked by Xcode, press Create Bridging Header. Do not delete the empty swift file.

Manually

If you are unable to add use_modular_headers! to your Podfile as it breaks your build (for instance, react-native-gesture-handler no longer compiles correctly), you can manually link the react-native-dji-mobile library to your project. Please note that this still requires the use of cocoapods to install the require DJI dependencies.

  1. Add the DJI Mobile SDK dependencies to your podfile and run pod install
+ pod 'DJI-SDK-iOS', '~> 4.10'
+ pod 'DJIWidget', '~> 1.5'
  1. Navigate to [YourProjectName]/node_modules/react-native-dji-mobile/ios

  2. Drag the ReactNativeDjiMobile.xcodeproj file into your Xcode project into the Libraries folder.

  3. Go to the Link Binary With Libraries build phase for your Xcode project, and add the libReactNativeDjiMobile.a.


Android (TODO)

Current Tags

  • 0.3.18                                ...           latest (9 months ago)

27 Versions

  • 0.3.18                                ...           9 months ago
  • 0.3.17                                ...           10 months ago
  • 0.3.16                                ...           a year ago
  • 0.3.15                                ...           a year ago
  • 0.3.14                                ...           a year ago
  • 0.3.13                                ...           a year ago
  • 0.3.12                                ...           a year ago
  • 0.3.11                                ...           a year ago
  • 0.3.10                                ...           a year ago
  • 0.3.9                                ...           a year ago
  • 0.3.8                                ...           a year ago
  • 0.3.7                                ...           a year ago
  • 0.3.6                                ...           a year ago
  • 0.3.5                                ...           a year ago
  • 0.3.4                                ...           a year ago
  • 0.3.3                                ...           a year ago
  • 0.3.2                                ...           a year ago
  • 0.3.1                                ...           a year ago
  • 0.3.0                                ...           a year ago
  • 0.2.2                                ...           a year ago
  • 0.2.1                                ...           a year ago
  • 0.2.0                                ...           a year ago
  • 0.1.1                                ...           a year ago
  • 0.1.0                                ...           a year ago
  • 0.0.7                                ...           a year ago
  • 0.0.6                                ...           a year ago
  • 0.0.5                                ...           a year ago
Maintainers (2)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 27
Dependencies (1)
Dev Dependencies (8)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |