react-coat-dev-pkg
Structured React + Redux with Typescript and support for isomorphic rendering beautifully
Last updated a year ago by wooline .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install react-coat-dev-pkg 
SYNC missed versions from official npm registry.

react 生态圈的开放、自由、繁荣,也导致开发配置繁琐、选择迷茫。react-coat 放弃某些灵活性、以约定替代某些配置,固化某些最佳实践方案,从而提供给开发者一个更简洁的糖衣外套。

请先花点时间了解一下:react-coat v4.0

本库是使用在 demo for react-coat 中的脚手架工具。因为,dev环境中的依赖很多,你可以安装本库,它将自动安装一系列的开发依赖,省心省力。

安装本库

$ npm install react-coat-dev-pkg

使用本库

参见:

入手:SPA(单页应用)

进阶:SPA(单页应用)+SSR(服务器渲染)

本库将安装:

  "dependencies": {
    "@types/express": "~4.16.0",
    "@types/node": "~10.12.2",
    "asset-require-hook": "~1.2.0",
    "axios": "~0.18.0",
    "babel-eslint": "~10.0.1",
    "chalk": "~2.4.1",
    "cross-env": "~5.2.0",
    "css-loader": "~1.0.0",
    "eslint": "~5.7.0",
    "eslint-config-airbnb-base": "~13.1.0",
    "eslint-config-prettier": "~3.3.0",
    "eslint-plugin-import": "~2.14.0",
    "eslint-plugin-prettier": "~3.0.0",
    "express": "~4.16.2",
    "file-loader": "~2.0.0",
    "fork-ts-checker-webpack-plugin": "~0.4.14",
    "fs-extra": "~7.0.0",
    "html-replace-webpack-plugin": "~2.5.5",
    "html-webpack-plugin": "~3.2.0",
    "json-format": "~1.0.1",
    "less": "~3.8.1",
    "less-loader": "~4.1.0",
    "micromatch": "~3.1.10",
    "mini-css-extract-plugin": "~0.4.4",
    "null-loader": "~0.1.1",
    "postcss-flexbugs-fixes": "~4.1.0",
    "postcss-loader": "~3.0.0",
    "postcss-preset-env": "~6.1.2",
    "postcss-pxtorem": "~4.0.1",
    "postcss-safe-parser": "~4.0.1",
    "prettier": "~1.15.2",
    "style-loader": "~0.23.1",
    "stylelint": "~9.8.0",
    "stylelint-config-prettier": "~4.0.0",
    "stylelint-config-standard": "~18.2.0",
    "stylelint-prettier": "~1.0.5",
    "stylelint-webpack-plugin": "~0.10.5",
    "ts-loader": "~5.2.2",
    "tslint": "~5.11.0",
    "tslint-config-prettier": "~1.15.0",
    "tslint-plugin-prettier": "~2.0.1",
    "tslint-react": "~3.6.0",
    "typescript": "~3.2.1",
    "url-loader": "~1.1.2",
    "webpack": "~4.21.0",
    "webpack-dev-server": "~3.1.14",
    "webpack-manifest-plugin": "~2.0.4",
    "yargs": "~12.0.2"
  },

Current Tags

  • 1.0.2                                ...           latest (a year ago)

10 Versions

  • 1.0.2                                ...           a year ago
  • 1.0.1                                ...           a year ago
  • 1.0.0                                ...           a year ago
  • 1.0.0-beta.4                                ...           a year ago
  • 1.0.0-beta.3                                ...           a year ago
  • 1.0.0-beta.2                                ...           a year ago
  • 1.0.0-beta.1                                ...           a year ago
  • 1.0.0-alpha.3                                ...           2 years ago
  • 1.0.0-alpha.2                                ...           2 years ago
  • 1.0.0-alpha                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 1
This Month 2
Last Day 1
Last Week 1
Last Month 15
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |