开发者社区> 镜像站> NPM> ra-data-aws-amplify
ra-data-aws-amplify
AWS amplify based GraphQL data provider for react-admin.
Last updated 8 months ago by morozov-dmytro .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install ra-data-aws-amplify 
SYNC missed versions from official npm registry.

ra-data-aws-amplify

A GraphQL data provider for react-admin built with AWS Amplify and tailored to target a simple GraphQL implementation.

Installation

Install with:

npm install --save ra-data-aws-amplify

or

yarn add ra-data-aws-amplify

Usage

import awsconfig from './aws-exports';
import * as queries from './graphql/queries.js'
import * as mutations from './graphql/mutations.js'
...
componentDidMount() {
    ...
    buildDataProvider({awsconfig, queries, mutations}) 
        .then(dataProvider => this.setState({ dataProvider }))
    ...
}
...

Contributing

Run the tests with this command:

make test

Current Tags

  • 0.2.0                                ...           latest (8 months ago)

2 Versions

  • 0.2.0                                ...           8 months ago
  • 0.1.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (4)
Dev Dependencies (3)
Dependents (0)
None