开发者社区> 镜像站> NPM> pouchdb-search
pouchdb-search
solr search for pouchdb
Last updated 7 years ago by cwmma .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install pouchdb-search 
SYNC missed versions from official npm registry.

pouchdb search

$ npm install pouchdb-search
var Pouch = require('pouchdb');
Pouch.plugin({'search': require('pouchdb-search')});

var db = Pouch('name');
db.search(func,options,callback);
db.search('design/name',options,callback);

In prgress, known issues:

  • like the pouch mapreduce and spatial plugins it does reindex with each query
  • only supports default indexes at the moment. Only supports queries from one index at a time

Current Tags

  • 1.0.1                                ...           latest (7 years ago)

9 Versions

  • 1.0.1                                ...           7 years ago
  • 1.0.0                                ...           7 years ago
  • 0.5.2                                ...           7 years ago
  • 0.5.1                                ...           7 years ago
  • 0.5.0                                ...           7 years ago
  • 0.4.0                                ...           7 years ago
  • 0.3.1                                ...           7 years ago
  • 0.3.0                                ...           7 years ago
  • 0.2.0                                ...           7 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (3)
Dev Dependencies (4)
Dependents (0)
None