oh-my-deps
Another script loader for the browser
Last updated 5 years ago by pateketrueke .
MIT · Original npm · Tarball · package.json
$ cnpm install oh-my-deps 
SYNC missed versions from official npm registry.

Oh my deps!

TravisCI NPM Bower

We want to do this:

oh.define 'dummy', ->
  (data) ->
    console.log 'DUMMY OUTPUT', data

oh.define 'moment', '/vendor/moment/moment.js'
oh.define 'moment/locale/es', '/vendor/moment/locale/es.js'

and then:

oh.require ['dummy', 'moment', 'moment/locale/es'], (dummy) ->
  dummy moment('19870610', 'YYYYMMDD').fromNow()

Consider the following constraints:

  • Calling oh.require() will load all scripts in sequence.
  • This script loader has no support for AMD/UMD.
  • This is not an RequireJS implementation.
  • Under development. ∞

Since 0.0.4 all callbacks are invoked after DOMContentLoaded is done.

OMD was designed for working with existing libraries in the Bower registry.

Most of them are in their own namespaces or their globals are not enough harmful.

Current Tags

  • 0.0.4                                ...           latest (5 years ago)

5 Versions

  • 0.0.4                                ...           5 years ago
  • 0.0.3                                ...           5 years ago
  • 0.0.2                                ...           5 years ago
  • 0.0.1                                ...           5 years ago
  • 0.0.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (0)
None
Dev Dependencies (2)
Dependents (2)

Copyright 2014 - 2016 © taobao.org |