node-nyaa-api
Nyaa.se API wrapper for the Node.js platform.
Last updated 2 years ago by bakaboykie .
GPL-3.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install node-nyaa-api 
SYNC missed versions from official npm registry.

node-nyaa

Nysaa.se Node.js API.

For now, this will only do two things; get the latest releases and search for releases. This is also only available in English (for now) because that's my own primary usecase.

Feel free to use this however you like, or send me a message/mail/PR if you would like to contribute.

Installation

$ npm install node-nyaa-api --save

Usage

var Nyaa = require('node-nyaa-api');


Nyaa.get_latest(function(err, articles) {
    if (err) throw err;

    console.log(articles);
});


Nyaa.search('danshi nichijou', function(err, articles) {
    if (err) throw err;

    for (var article in articles)
        console.log(articles[article].title);
});

License

This program is licensed under the GPL-3.0 license.

Current Tags

  • 1.0.0                                ...           latest (2 years ago)

2 Versions

  • 1.0.0                                ...           2 years ago
  • 0.0.1                                ...           4 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (4)
Dev Dependencies (0)
None
Dependents (2)

Copyright 2014 - 2016 © taobao.org |