noddy
Parse a Node.js version and compare with another one.
Last updated 3 years ago by zvr .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install noddy 
SYNC missed versions from official npm registry.

noddy

npm version

noddy is a Node.js package which allows to parse process.version string into major, minor and patch numbers, and compare a specific version with the current one.

npm i noddy

ES5

The package uses some newer language features. For your convenience, it's been transpiled to be compatible with Node 4. You can use the following snippet.

const noddy = require('noddy/es5')

API

The package provides a set of functions.

noddy.parseVersion(version?: string): { major: number, minor: number, patch: number }

Call parseVersion to extract the version object from the version string. Don't pass an argument to parse the current Node.js version.

const { parseVersion } = require('noddy')

parseVersion() // { major: 8, minor: 9, patch: 3 }
parseVersion('v5.10.0') // { major: 5, minor: 10, patch: 0 }

noddy.nodeGt(version?: string): boolean

Check if the current Node.js version is greater than the specified one.

const { nodeGt } = require('noddy')

process.version // v8.9.3
nodeGt('v2.3.4') // true
nodeGt(process.version) // false
nodeGt('v20.3.4') // false

noddy.nodeGte(version?: string): boolean

Check if the current Node.js version is greater than or equal to the specified one.

const { nodeGte } = require('noddy')

process.version // v8.9.3
nodeGte('v2.3.4') // true
nodeGte(process.version) // true
nodeGte('v20.3.4') // false

noddy.nodeLt(version?: string): boolean

Check if the current Node.js version is less than the specified one.

const { nodeLt } = require('noddy')

process.version // v8.9.3
nodeLt('v2.3.4') // false
nodeLt(process.version) // false
nodeLt('v20.3.4') // true

noddy.nodeLte(version?: string): boolean

Check if the current Node.js version is less than or equal to the specified one.

const { nodeLte } = require('noddy')

process.version // v8.9.3
nodeLte('v2.3.4') // false
nodeLte(process.version) // true
nodeLte('v20.3.4') // true

(c) sobes.io 2018

Current Tags

  • 1.1.1                                ...           latest (3 years ago)

3 Versions

  • 1.1.1                                ...           3 years ago
  • 1.1.0                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 0
Last Month 5
Dependencies (0)
None
Dev Dependencies (2)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |