neutrino-middleware-browser-sync
Neutrino middleware for BrowserSync
Last updated 3 years ago by indigofeather .
MIT · Repository · Original npm · Tarball · package.json
$ cnpm install neutrino-middleware-browser-sync 
SYNC missed versions from official npm registry.

Neutrino middleware with BrowserSync

NPM version

neutrino-middleware-browser-sync is a Neutrino middleware that adds BrowserSync support.

Requirements

  • Node.js v6 LTS, v8, v9
  • Yarn v1.2.1+, or npm v5.4+
  • Neutrino v8

Installation

Yarn

❯ yarn add --dev neutrino-middleware-browser-sync

npm

❯ npm install --save-dev neutrino-middleware-browser-sync

Documentation

Install this middleware to your development dependencies, then set it in .neutrinorc.js:

  module.exports = {
    use: [
      'neutrino-middleware-browser-sync', {
        browserSyncOptions: {
          port: 4000
        },
        pluginOptions: {
          reload: false
        }
      }
    ]
  }

Current Tags

  • 2.1.0                                ...           latest (3 years ago)

11 Versions

  • 2.1.0                                ...           3 years ago
  • 2.0.2                                ...           3 years ago
  • 2.0.1                                ...           3 years ago
  • 2.0.0                                ...           3 years ago
  • 1.1.2                                ...           3 years ago
  • 1.1.1                                ...           3 years ago
  • 1.1.0                                ...           3 years ago
  • 1.0.3                                ...           3 years ago
  • 1.0.2                                ...           3 years ago
  • 1.0.1                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 3
This Month 3
Last Day 0
Last Week 0
Last Month 2
Dependencies (3)
Dev Dependencies (0)
None
Dependents (1)

Copyright 2014 - 2016 © taobao.org |