mincer-babel-engine
**ProjectStats** [![npm version](https://badge.fury.io/js/mincer-babel-engine.svg)](https://badge.fury.io/js/mincer-babel-engine) [![Dependency Status](https://gemnasium.com/badges/github.com/damncreative/mincer-babel-engine.svg)](https://gemnasium.com/gi
Last updated 4 years ago by naxmefy .
MIT · Original npm · Tarball · package.json
$ cnpm install mincer-babel-engine 
SYNC missed versions from official npm registry.

mincer-babel-engine

ProjectStats npm version Dependency Status

TravisCI Build Status

Coveralls Coverage Status

Codacy Codacy Badge Codacy Badge

NPM

installation

$ npm install mincer-babel-engine

usage

var babelEngine = require('mincer-babel-engine');
var Mincer = require('mincer');

babelEngine(Mincer);

Lib Function

babelEngine(mincer [,options] [,babel-core])

var babelEngine = require('mincer-babel-engine');
var mincer = require('mincer');
var babelCore = require('babel-core');

// examples
babelEngine(mincer); // with mincer
babelEngine(mincer, {}); // with mincer and options
babelEngine(mincer, {}, babel); // with mincer, options and own babel-core

options

  • extensions Supported extensions by this engine. (Array of Strings. Default: ['.es6'])
  • babel Babel options to use for transform. (Object. Default: {})

configure

Mincer.BabelEngine.configure(options)

// ...
Mincer.BabelEngine.configure({
  preset: ['es2015']
});

Hint: The object in configure is passed to babel property of engine options.

Contribute

  • Bug? Missing Feature? Open Issue!
  • or Fork, Implement and open Pull Request

LICENSE

MIT

Current Tags

  • 0.2.0                                ...           latest (4 years ago)

2 Versions

  • 0.2.0                                ...           4 years ago
  • 0.1.0                                ...           4 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (3)
Dev Dependencies (4)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |