markdown-magic-engines
Render engine requirements in Markdown files via Markdown Magic
Last updated 2 years ago by camacho .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install markdown-magic-engines 
SYNC missed versions from official npm registry.

markdown-magic-engines

Print engine requirements from package.json via markdown-magic

Install

yarn add -D markdown-magic markdown-magic-engines

Note: markdown-magic is a peer dependency and must be installed separately from this module

Adding the plugin

See example.js for usage.

const fs = require('fs');
const path = require('path');
const markdownMagic = require('markdown-magic');

const config = {
  transforms: {
    ENGINES: require('./index.js'),
  },
};

const markdownPath = path.join(__dirname, 'README.md');
markdownMagic(markdownPath, config);

Usage in markdown

  • node: >=6.0.0

Current Tags

  • 1.0.2                                ...           latest (2 years ago)

3 Versions

  • 1.0.2                                ...           2 years ago
  • 1.0.1                                ...           3 years ago
  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 1
Last Month 3
Dependencies (1)
Dev Dependencies (3)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |